Using example lib-jitsi-meet.js Problem

Hi, sorry i want to ask this. I try example in lib-jitsi-meet in localhost, but i have error below, I try to deployed to my server and using protocol HTTPS but have same error. How to fix it? Thanks…

in my config I use:

const options = {
hosts: {
    domain: 'meet.jit.si',
    muc: 'conference.meet.jit.si' // FIXME: use XEP-0030
},
bosh: 'https://meet.jit.si/http-bind', // FIXME: use xep-0156 for that

// The name of client node advertised in XEP-0115 'c' stanza
clientNode: 'http://jitsi.org/jitsimeet'

};

and this my error :

Logger.js:154 2020-04-13T00:54:22.453Z [modules/xmpp/xmpp.js] <t.value>:  (TIME) 
Strophe connfail[item-not-found]:	 3380.910000007134
strophe.stream-management.js:207 Uncaught TypeError: CreateListFromArrayLike called 
on non-object
at o._interceptDoDisconnect (strophe.stream-management.js:207)
at O.Connection._dataRecv (strophe.umd.js:3140)
at I.Bosh._onRequestStateChange (strophe.umd.js:5012)
_interceptDoDisconnect @ strophe.stream-management.js:207
 _dataRecv @ strophe.umd.js:3140
_onRequestStateChange @ strophe.umd.js:5012
 XMLHttpRequest.send (async)
u @ strophe.umd.js:5123
_processRequest @ strophe.umd.js:5137
 _throttledRequestHandler @ strophe.umd.js:5290
_onIdle @ strophe.umd.js:4901
_onIdle @ strophe.umd.js:3881
(anonymous) @ strophe.umd.js:5257
 setTimeout (async)
_send @ strophe.umd.js:5256
 send @ strophe.umd.js:2583
_attemptSASLAuth @ strophe.umd.js:3364
authenticate @ strophe.umd.js:3319
_connect_cb @ strophe.umd.js:3271
_onRequestStateChange @ strophe.umd.js:5012
XMLHttpRequest.send (async)
u @ strophe.umd.js:5123
_processRequest @ strophe.umd.js:5137
_throttledRequestHandler @ strophe.umd.js:5290
_connect @ strophe.umd.js:4586
connect @ strophe.umd.js:2368
_interceptConnectArgs @ strophe.stream-management.js:213
value @ XmppConnection.js:211
value @ xmpp.js:384
value @ xmpp.js:444
c.connect @ JitsiConnection.js:61
(anonymous) @ create.js:308
Logger.js:154 2020-04-13T00:54:23.196Z [modules/RTC/RTCUtils.js] 
onUserMediaSuccess

image

@Rabihi_Awaludin did you get fix for this error?