Using API - Setting language default possible

Hello there,

i´m using jitsi on a webpage and everything is working fine. Now a client asked me if it´s possible to change the default language to “DE”. Is that possible using the right var option?

Did i something wrong with the overwrite. Because it´s not working:

$(document).ready(function() {
 var domain = "meet.jit.si";
var options = {
    roomName: "myroomxy",
    width: 800,
    height: 583,
    interfaceConfigOverwrite: {LANG_DETECTION: true},
    parentNode: document.querySelector("#vmeet")
}

var api = new JitsiMeetExternalAPI(domain, options);
});

Would be great hearing from you.

Best regards,

Alvaro

Have you tried in an incognito window? I recall there was an issue in jitsi-meet for a while where the default language wasn’t being overridden after the first page load. There is also config.defaultLanguage which you can override.

Hello Lenny,

thanks for responding so quick. The incognito window didn´t work. I´ve tried to override the config with the default language. But i think i did it wrong because it didn´t work.

// Default language for the user interface.
// defaultLanguage: ‘en’,

I did this in options:
interfaceConfigOverwrite: { defaultLanguage: ‘de’ },

That setting is not for interface-config, this is for config.js https://github.com/jitsi/jitsi-meet/blob/master/config.js#L263
Use configOverwrite and test in incognito.

Great! It´s working now.

configOverwrite: { defaultLanguage: ‘de’ },

Thank you very much!

Btw. May i ask you how to remove the jitsi watermark? I did not find any explanation using the api.

If you are using meet.jit.si as a backend we kindly ask people to no remove it. There is no such option in the configuration.
If you are using your own deployment you can replace the image with your own.

I see. No problem. Wouldn´t it be possible to show the logo for 10 seconds after login and then it disappears? Or you can put a section with “powered by jitsi” on the frame. Well, just an idea. Thanks again!

Where do I add this line? In which file?

configOverwrite: { defaultLanguage: ‘en’ },

I have edited main.json file. But it’s not taking any effect. I have tried in incognito mode.

Honestly, i don´t know. What i did was editing a html file using the api. But i think damencho is able to answer your question.

@damencho Can you please answer where should I add that line?

Can you please tell which html file?

Or can you explain the steps how you did it?

That is a parameter you pass to the iframe api.

If you edit main.json, you also need to rebuild the app, cause this is the default language and it is embedded in the app.bundle js file.

How do I pass the parameter to the iframe api? Can you please explain it?

Also, I have installed Jitsi from the nightly build. How do I rebuild it?


One of the options you pass is: configOverwrite

Read “Building the sources” https://github.com/jitsi/jitsi-meet#building-the-sources

Thanks

Is there any easy way to modify the language?

I have 2 questions:

  1. How can I set the redirection page on conference hangup to a different html file rather than close2.html?
  2. How can I mute a user and lock him so that he/she cannot unmute? There is a similar lock feature in Bigbluebutton.

main.json is embeded in the app.bundle, so there is no other way, than creating new bundle.

You can overwrite that in nginx and use a custom close2.html page.

There is no such feature.