Using and/or installing jitsi on kubuntu 18.04


I’d like to use jitsi to attend a remote LUG meeting.
When I tried the web version, it said it couldn’t access my mic or camera on my notebook.

When I tried to install it following your instructions I got stuck with a bunch of error messages.
I also added a few notes and the tag “ERROR:” before a couple of sections where something looks like it failed.



What is the address that you tried? What is the browser you use? Is it working on What about

You had uploaded an emtpty file.


Thanks for the reply. Sorry about that!

I’m having some issues with GDrive integration with KDE. Hopefully, this link should work. I’ll test it as soon as this posts.

I’m trying to access “wnclug meeting” using the Vivaldi 2.2 browser. It’s setup (by someone else) for a meeting in the near future and I wanted to iron out the bugs before trying to attend the meeting.

Got further with Firefox 52 (last ESR before Quantum broke all my add-ons). It asks me for permission to use the camera and then that works, but it never asks for my mic - just says it can’t access it.

Just turned off disable HTML5 Autoplay in Vivaldi and now video works there too. Still no mic.

Narrowed it down. Went into system setting and selected Analog Stereo Duplex. Now camera and mic work in Firefox 52.
Also went into pulseaudio volume control and did something with the mic there too - don’t remember what.

I’ll have to research Vivaldi a bit more.

I’m still interested in the problems installing the package


Mind that Vivaldi is not tested, so not sure what’s working and what not. Try using chrome/chromium …
Firefox 52 is too old …

Have you checked this from the quick install “Also note that a recent default Ubuntu installation has only the main repository enabled, and Jitsi Meet needs packages from universe . Check your /etc/apt/sources.list file, and if universe is not present refer to Ubuntu’s documentation on how to enable it. (Usually it amounts to copying the main lines and changing to universe .)”,

I suspect you are hitting this …


I already have universe and multiverse repositories enabled by default.

Firefox 52 may be old, but it works - including with jitsi. I only use it on trusted sites when I need the functionality of some of my add-ons that no longer work with Quantum (Firefox 60.0+).

It looks like the most obvious error is

The given hostname does not exist in the config

I did some searching.
One thread (that you are in) mentions


That directory/file does not exist on my system.

Looked further and the main problem seems to be end user malfunction. :wink: I’m not used to using things I don’t need to install.

I found your manual install page and it’s all about servers that I don’t need.

So, I’m going to purge jitsi and just use it with Firefox and your web service when I need it.

Thanks for your efforts.


If you haven’t tried Vivaldi, it’s an amazing browser for power users. And, if you understand this stuff, you’re definitely a power user!

It’s based on chromium and is highly configurable and customizable. If you use a lot of tabs, there are tons of management features for them.

It has web panels that you can tuck away in a sidebar. You could have jitsi running in one of them and pop it on and off screen with a single mouse click or hotkey and it stays available as you switch tabs and browser windows.

Some of the people responsible for the Opera browser (up to version 12) are the ones behind Vivaldi. There’s a great community as well.


On a second look at the logs I see that you are entering localhost as a desired domain, is this correct?
You should be entering a valid DNS that others will use to connect to your conference. For testing purposes you can try an ip address, but with it you cannot use let’s encrypt or mobile, don’t use localhost cause I think it cause problems as prosody maybe coming with a preconfigured host localhost.