Using alternate port has broken screen sharing with Chrome browsers

We’ve been successfully deployed many a jitsi meet on debian 10 for quite a while now, but we moved jitsi from port 443 to 6443 in December. In other words, we let Nginx serve an alternate landing page but users can click into jitsi from there which takes them to https://aaa.bbb.com:6443/ upon which they see the Jitsi landing page.

So jitsi-meet has been happily running on port 6443 since December. Our meetings have been good for the most part. Recently (since 2/1 it seems) users can create secured meeting rooms and everything works but desktop sharing. That still works in FireFox and Safari, but not Chrome or Chromium (Brave etc).

In the Chrome console I’m seeing:
BridgeChannel.js:83 WebSocket connection to ‘wss://aaa.bbb.com/colibri-ws/default-id/d73991bb5b2fd6ac/766fbcd0?pwd=7j2dne797ea938i63fu0s9k5er’ failed:
_initWebSocket @ BridgeChannel.js:83
Logger.js:154 2022-02-13T06:19:16.094Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>: Channel closed by server
react_devtools_backend.js:4061 2022-02-13T06:19:16.094Z [modules/RTC/BridgeChannel.js] <WebSocket.e.onclose>: Channel closed: 1006
overrideMethod @ react_devtools_backend.js:4061

In FireFox I see:
Firefox can’t establish a connection to the server at wss://aaa.bbb.com/colibri-ws/default-id/d73991bb5b2fd6ac/a548fbc2?pwd=3fqlhle41d42bo9sgvoidqv9ft. BridgeChannel.js:83:19

2022-02-13T06:21:55.396Z [modules/RTC/BridgeChannel.js] <1492/_handleChannel/e.onclose>: Channel closed by server

I think we should see: wss://aaa.bbb.com:6443/colibri-ws/default-id/d73991bb5b2fd6ac/a548fbc2?pwd=3fqlhle41d42bo9sgvoidqv9ft

Any suggestions on how we can get this running (again)? I can’t confirm that desktop sharing worked, the QA folks have older VMs in which it is working, so this seems new. In any case, it would be awesome to get it working again.

The jitsi-meet installed is: 2.0.6865-2
I’ve also reverted to 2.0.6726-1 with the same issue.

I should note that editing the nginx config and the config.js bosh setting back to defaults works perfectly in all regards. Just not on port 6443.

Looks like we didn’t set the jvb.conf port setting. Thanks for the tip!

We are now operating normally.