User's in seprate JVB cannot see or hear each other

Hi,

I have a JMS running using docker-compose on a server and two JVB are added to the jicofo but and I have enabled OCTO and used the split strategy but users who land on the same JVB can only see or talk to each other.
@saghul can u please help here

Is this setup behind a firewall ?

yeah i tried removing from firewall also. still the same issue.

Can you draw a rough diagram which shows your architecture with proper port mapping and type ?

in my jicofo logs i can see jvb getting added succesfully with relay id and all.
but in browser console logs am getting error like below.


and that 172.19.0.2 seems to be container ip. i think that’s where the problem lies.

@saghul @damencho @tusharsonawane can u please help here

Have you handled the websocket for different jvbs: jitsi-meet/jitsi-meet.example at e10e9a5feca2f311071949fccc94f77b961fbc1a · jitsi/jitsi-meet · GitHub

You can do it dynamic like docker: docker-jitsi-meet/meet.conf at 65563d93710c5c001e7f898b16f29747709509c1 · jitsi/docker-jitsi-meet · GitHub
docker-jitsi-meet/jvb.conf at 65563d93710c5c001e7f898b16f29747709509c1 · jitsi/docker-jitsi-meet · GitHub


my nginx.conf is same


but in my jvb.conf server-id is coming as docker container ip.

@saghul @damencho @tusharsonawane can you please help here.


am getting this error on web container. this 178.18.0.2 seems to be container ip.

hello, @damencho @tusharsonawane @saghul I fixed the issue with WebSocket connection by adding JVB_WS_SERVER_ID as public IP in my jvb’s. but now the real problem comes users who land on the same jvb are able to see and hear.

Did you use different public IPS for your jvbs ?

As in, if you have 5 jvb’s, you used 5 different public IP’s ?

Now I can not able to access my firewall, what to do now?

i was able to fix this by adding JVB_WS_SERVER_ID and my octo port was running as TCP changed to UDP now everything works fine.

How have you solved the issue?
Could you please share the configurations of meet.conf, jvb.conf, sip-communicator.properites and jicofo.conf that you have changed?

are you doing a docker installation? what problem are you facing exactly?

I am using docker installation. I have configured OCTO in my deployment with 2 JVB on different machines. Participants of a single meeting are distributed across them based on SplitBridgeSelectionStrategy.

But, participants from JVB1 cannot hear the participants from JVB2.
Public IP address of the machines has been set to server-id of jvb.conf. 4096 port is exposed to Docker Host through port mapping which can be realized from docker ps command.

Any insight you have regarding this? If you share the configurations, it could be of great help.

what is your 4096 port? is it tcp or udp. and are you getting any error on browser console.

4096/udp port is used.

Errors in browser logs:

Error 1: [JitsiConference.js] <u.sendMessage>: Failed to send E2E ping request or response. undefined

Error 2: [modules/RTC/BridgeChannel.js] <l._send>: Bridge Channel send: no opened channel.

Error 3: [modules/xmpp/ChatRoom.js] <E.onPresence>: Jicofo supports restart by terminate: true
Logger.js:154 2021-06-27T11:51:00.780Z [modules/connectivity/IceFailedHandling.js] <i._conference.jvbJingleSession.terminate.reason>: session-terminate for ice restart - error: undefined

Could you please help me in this regard.

when you start jvbs are you able to see logs related to the addition of jvbs in jicofo logs?