Users do not see or hear each other, but they do connect to the room

Hello dears,

I did the installation and configuration of jitsi on my local server, following this tutorial

Everything works fine, except you can’t see the video or listen to the audio on the self-hosted instance with users outside the local network.

I applied these changes:
"The following additional lines should be added to the /etc/jitsi/videobridge/sip-communicator.properties file:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<local.IP.address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=

And I commented out the existing org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES.
"

But it didn’t work for me.

damencho provided the following solution, but I don’t know where this code applies:

Cannot see video or hear audio on self-hosted instance?

"You need to configure the public and private addresses as indicated in the advanced settings, your jvb only advertises your private address:
a=candidate:1 1 tcp 2130706431 10.142.0.2 4443 typ host tcptype generation passive 0
a=candidate:2 1 udp 2130706431 10.142.0.2 10000 host generation type 0
a=sendrecv
"
Please I will appreciate your comments.
Thanks.

Have you configured the port forwarding also?

Remote participants should be able to access TCP/443 and UDP/10000 of Jitsi server. Since your remote participants can access Jitsi UI, you should have done TCP/443 forwarding already.

Did you repeat the same steps for UDP/10000 too?

Hi Emrah, thanks for your time

I did not do any forwarding of those ports. What I did was follow the procedure indicated in this link: Self-Hosting Guide - Debian/Ubuntu server | Jitsi Meet fqdn-optional

This is what I did:

Ubuntu 20.04

1.- sudo apt update
2.- ufw allow OpenSSH
3.- ufw enable

4.- sudo apt install nginx
5.- sudo ufw allow ‘Nginx HTTP’

6.- sudo apt install default-jdk
7.- sudo apt install gnupg2

I continued with what this procedure indicates:

8.- # Retrieve the latest package versions across all repositories
sudo apt update

6.- # Ensure support for apt repositories served via HTTPS
sudo apt install apt-transport-https

7.- sudo apt-add-repository universe

8.- sudo apt update

9.- sudo hostnamectl set-hostname meet.example.org

10.- Then add the same FQDN in the /etc/hosts file:
127.0.0.1 localhost
x.x.x.x meet.example.org

11.- echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list
wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -
apt install lua5.2

12.- curl https://download.jitsi.org/jitsi-key.gpg.key | sudo sh -c ‘gpg --dearmor > /usr/share/keyrings/jitsi-keyring.gpg’
echo ‘deb [signed-by=/usr/share/keyrings/jitsi-keyring.gpg] https://download.jitsi.org stable/’ | sudo tee /etc/apt/sources.list.d/jitsi-stable.list > /dev/null

13.- sudo apt update

14.- sudo ufw allow 80/tcp
sudo ufw allow 443/tcp
sudo ufw allow 10000/udp
sudo ufw allow 22/tcp
sudo ufw allow 3478/udp
sudo ufw allow 5349/tcp
sudo ufw enable

sudo ufw status verbose

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), deny (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
80/tcp (Nginx HTTP)        ALLOW IN    Anywhere                  
22/tcp (OpenSSH)           ALLOW IN    Anywhere                  
80/tcp                     ALLOW IN    Anywhere                  
443/tcp                    ALLOW IN    Anywhere                  
10000/udp                  ALLOW IN    Anywhere                  
22/tcp                     ALLOW IN    Anywhere                  
3478/udp                   ALLOW IN    Anywhere                  
5349/tcp                   ALLOW IN    Anywhere                  
80/tcp (Nginx HTTP (v6))   ALLOW IN    Anywhere (v6)             
22/tcp (OpenSSH (v6))      ALLOW IN    Anywhere (v6)             
80/tcp (v6)                ALLOW IN    Anywhere (v6)             
443/tcp (v6)               ALLOW IN    Anywhere (v6)             
10000/udp (v6)             ALLOW IN    Anywhere (v6)             
22/tcp (v6)                ALLOW IN    Anywhere (v6)             
3478/udp (v6)              ALLOW IN    Anywhere (v6)             
5349/tcp (v6)              ALLOW IN    Anywhere (v6) 

15.- # jitsi-meet installation
sudo apt install jitsi-meet

16.- sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

17.- The following extra lines need to be added to the file /etc/jitsi/videobridge/sip-communicator.properties:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=<Local.IP.Address>
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=<Public.IP.Address>

And comment the existing org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES.

How and where should this forwarding be done?

I appreciate your help

Hello damencho,

I haven’t done that, how do you configure port forwarding? I don’t understand this part very well.

I will appreciate it if you can explain to me in which part it is done.

Thank you very much.

forwarding” is not directly related with Jitsi setup. It is related with your network environment. You should do it on your router/firewall.

Solved, thank you.

By default the system creates the rule for tcp:443, but does not create it for udp:10000. This rule must be created manually.

Regards

What system?

Google cloud platform, when creating the virtual machine and setting the firewall to allow HTTP and HTTPS traffic, automatically creates the rules:

Name Type Destination Filters Protocols/ports
default-allow-http Entry http-server IP ranges: 0.0.0.0/0 tcp:80

default-allow-https Entry https-server IP Ranges: .0.0.0/0 tcp:443

But not so for udp:10000 and that rule must be created manually.

:+1: