Users cannot enter room with JWT Authentication

Hello,

I configured JWT on Debian 10 according to this guide: https://github.com/jitsi/lib-jitsi-meet/issues/1082#issuecomment-616948457
I use Rocket.Chat to generate the JWT token, it seems to be valid when I inspect it at jwt.io. However, when users open the link they don’t get placed in the conference, you never fully connect.

Some logs that might be interesting:
Jicofo starts up pretty normal, one thing I notice:

WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler (file:/usr/share/jicofo/lib/dom4j-1.6.1.jar) to method com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()
WARNING: Please consider reporting this to the maintainers of org.dom4j.io.SAXContentHandler
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release

Prosody when I join:

Apr 26 14:22:19 conference.meet.example.com:muc_domain_mapper   warn    Session filters applied
Apr 26 14:22:19 mod_bosh        info    New BOSH session, assigned it sid 'cec833a0-a478-4d41-b79b-9cb216a74b10'
Apr 26 14:22:19 boshcec833a0-a478-4d41-b79b-9cb216a74b10        warn    No available SASL mechanisms, verify that the configured authentication module is working
Apr 26 14:22:26 speakerstats.meet.example.com:speakerstats_component    warn    A module has been configured that triggers external events.
Apr 26 14:22:26 speakerstats.meet.example.com:speakerstats_component    warn    Implement this lib to trigger external events.

JVB joins the MUC just fine.

Browser logs are normal as well, what I notice is:

[modules/xmpp/strophe.util.js] <t.a/r.Strophe.log>:  Strophe: Server did not yet offer a supported authentication mechanism. Sending a blank poll request.

In the prosodyconfig I just added

 app_id = "rocketchat"
 app_secret = "thisinsanelysecretsecret"
 allow_empty_token = false

to the VHost, set c2s_require_encryption to false and enabled the token_verification module for the conference.meet.example.com Component

Any help would be appreciated!

icofo 2020-05-23 12:10:48.123 INFO: [12] org.jitsi.jicofo.health.Health.log() Started with interval=9223372036854775807, timeout=PT30S, maxDuration=PT20S, stickyFailures=false.
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.dom4j.io.SAXContentHandler (file:/usr/share/jicofo/lib/dom4j-1.6.1.jar) to method com.sun.org.apache.xerces.internal.parsers.AbstractSAXParser$LocatorProxy.getEncoding()
WARNING: Please consider reporting this to the maintainers of org.dom4j.io.SAXContentHandler
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release