Username and password fails

Hi,

I’ve made a new jitsi server in digital ocean
meet.chemicalworld.mx

I want to set a username and password in order to make the moderator log in for the room and allow the lobby settings by default

I edited this file
/etc/prosody/conf.avail/meet.chemicalworld.mx.cfg.lua

Like this

VirtualHost "meet.chemicalworld.mx"
    authentication="internal_plain"

And at the end of the file I wrote

 VirtualHost "guest.meet.chemicalworld.mx"
      authentication = "anonymous"
          c2s_require_encryption = false

I registered the user and the edited this file
/etc/jitsi/meet/meet.chemicalworld.mx-config.js

Like this

hosts: {
        // XMPP domain.
        domain: 'meet.chemicalworld.mx',

        // When using authentication, domain for guest users.
         anonymousdomain: 'guest.meet.chemicalworld.mx',

Then I edited this file
/usr/share/jitsi-meet/prosody-plugins/mod_muc_lobby_rooms.lua

To make the lobby enabled by default like this

       if lobby_muc_service and room._data.lobbyroom then
            local lobby_room_obj = lobby_muc_service.get_room_from_jid(room._data.lobbyroom);
            if lobby_room_obj then
                local occupant = lobby_room_obj:get_occupant_by_real_jid(invitee);
                if occupant then
                    local display_name = occupant:get_presence():get_child_text(
                            'nick', 'http://jabber.org/protocol/nick');

                    notify_lobby_access(room, from, occupant.nick, display_name, true);
                end
            end
        end
    end);
    -- inicia parche
        host_module:hook('muc-set-affiliation', function(event)
         if jid_split(event.jid) ~= 'focus' and event.affiliation == 'owner' then
                    handle_create_lobby(event);
              end
           end);
        --fin parche
end);

And restarted everything

service nginx restart && service jitsi-videobridge2 restart && service prosody restart && service jicofo restart

But when you enter to the url, you can start a room without credentials. Why?

Thank you in advance

Follow this doc to enable authentication Secure Domain setup | Jitsi Meet
There are changes you need to do in jicofo

Thank you, I’ve made the changes but now, it starts the prompt of the login but doesn’t accept the credentials. It returns the input pop up

Can you try to unregister and register the user again? Or try a new user.

Thank you, I tried that too but it only worked when I wrote back authentication=“internal_plain” in the file /etc/prosody/conf.avail/meet.chemicalworld.mx.cfg.lua

Accordiing with the link of damencho, the authentication had to be internal_hashed; but it wasn’t accepted. I don’t know why; but with internal_plain it worked

Thank you all

What I have noticed, is that there is a delay on something

When the moderator logs in, even though the user and password is accepted, the system pops up again as if it was rejected; but a few seconds later, it starts normally

I don’t know if I can upload a video to show this behaviour

These are two different types of database for prosody. They keep the data differently. If you register the user while internal_plain is enabled, you cannot acces it after switching to internal_hashed.

But it seems that you already solved the account issue.

Yes, the account issue is now solved; but the weird thing is that the login has some delay, because it’s accepted but the moderator still needs to wait while the pop up to login is prompted again. I think it could be easier to explain if I share a video; but I don’t know if it’s possible to do it in the forum