User registration fails

Hello,
I installed Linux Jitsi-Meet on a current Debian Buster (10.4) (https://www.digitalocean.com/community/tutorials/how-to-install-jitsi-meet-on-debian-10-de).
If I now want to create users as moderators, I fail:

prosodyctl register Bobic meet.domain.de Ahz1quon
Error: Account creation/modification not supported.

In an installation three days earlier with the same settings and installations, I do not have this error. Now I don’t know what’s going wrong there.

Best regards

BrotherJ

are you sure you have a host where authentication is actually enabled ?

are you sure you have a host where authentication is actually enabled ?
What do you mean exactly? I have the exact instructions above, reproduced in two installations. It works for the first, this error occurs for the second.

a prosody host is a section named VirtualHost in the /etc/prosody/conf.avail/yoursite.cfg.lua and you should have one named “yoursite” with authentication = (prosody auth) such as internal_plain, internal_hashed.

Here is the whole config file included VirtualHost:
/etc/prosody/conf.avail # cat meet.domain.de.cfg.lua
plugin_paths = { “/usr/share/jitsi-meet/prosody-plugins/” }

-- domain mapper options, must at least have domain base set to use the mapper
muc_mapper_domain_base = "meet.domain.de";

turncredentials_secret = "BmEsDKVAVfjgYd08";

turncredentials = {
  { type = "stun", host = "meet.domain.de", port = "4446" },
  { type = "turn", host = "meet.domain.de", port = "4446", transport = "udp" },
  { type = "turns", host = "meet.domain.de", port = "443", transport = "tcp" }
};

cross_domain_bosh = false;
consider_bosh_secure = true;
-- https_ports = { }; -- Remove this line to prevent listening on port 5284

VirtualHost "meet.domain.de"
        -- enabled = false -- Remove this line to enable this host
        authentication = "anonymous"
        -- Properties below are modified by jitsi-meet-tokens package config
        -- and authentication above is switched to "token"
        --app_id="example_app_id"
        --app_secret="example_app_secret"
        -- Assign this host a certificate for TLS, otherwise it would use the one
        -- set in the global section (if any).
        -- Note that old-style SSL on port 5223 only supports one certificate, and will always
        -- use the global one.
        ssl = {
                key = "/etc/prosody/certs/meet.domain.de.key";
                certificate = "/etc/prosody/certs/meet.domain.de.crt";
        }
        speakerstats_component = "speakerstats.meet.domain.de"
        conference_duration_component = "conferenceduration.meet.domain.de"
        -- we need bosh
        modules_enabled = {
            "bosh";
            "pubsub";
            "ping"; -- Enable mod_ping
            "speakerstats";
            "turncredentials";
            "conference_duration";
        }
        c2s_require_encryption = false

Component "conference.meet.domain.de" "muc"
    storage = "memory"
    modules_enabled = {
        "muc_meeting_id";
        "muc_domain_mapper";
        -- "token_verification";
    }
    admins = { "focus@auth.meet.domain.de" }
    muc_room_locking = false
    muc_room_default_public_jids = true

-- internal muc component
Component "internal.auth.meet.domain.de" "muc"
    storage = "memory"
    modules_enabled = {
      "ping";
    }
    admins = { "focus@auth.meet.domain.de", "jvb@auth.meet.domain.de" }
    muc_room_locking = false
    muc_room_default_public_jids = true

VirtualHost "auth.meet.domain.de"
    ssl = {
        key = "/etc/prosody/certs/auth.meet.domain.de.key";
        certificate = "/etc/prosody/certs/auth.meet.domain.de.crt";
    }
    authentication = "internal_plain"

Component "focus.meet.domain.de"
    component_secret = "4qlE7VcC"

Component "speakerstats.meet.domain.de" "speakerstats_component"
    muc_component = "conference.meet.domain.de"

Component "conferenceduration.meet.domain.de" "conference_duration_component"
    muc_component = "conference.meet.domain.de"

VirtualHost "guest.meet.domain.de"
    authentication = "anonymous"
    c2s_require_encryption = false

Maybe you see a mistake.

well, if your domain is anonymous I don’t see the point in creating users (and Prosody agrees with me)

I don’t understand it, because on my testing system exactly the same runs well:

VirtualHost “guest.meet.domain.local”
authentication = “anonymous”
c2s_require_encryption = false

Both installations follow this description here https://www.digitalocean.com/community/tutorials/how-to-install-jitsi-meet-on-debian-10-de

Fügen Sie dann in der gleichen Datei folgenden Abschnitt am Ende der Datei hinzu:

/etc/prosody/conf.avail/your_domain.cfg.lua

...
VirtualHost "guest.your_domain"
    authentication = "anonymous"
    c2s_require_encryption = false

Diese Konfiguration ermöglicht es anonymen Benutzern, Konferenzräumen beizutreten, die von einem authentifizierten Benutzer erstellt wurden. Der Gast muss jedoch über eine eindeutige Adresse und ein optionales Passwort für das Betreten des Raums verfügen.

VirtualHost "meet.domain.de"
        -- enabled = false -- Remove this line to enable this host
        authentication = "anonymous"

Okay, sorry! I haven’t noticed it. The command grep about both files shows the difference.
authentication = "internal_plain"
is the right parameter.
Thank you for your support!