Use stun turn for multiparty in restricted network


#1

i have a coturn server which is working with my jitsi deployment. it works with p2p. i was wondering if it is possible to use it for multi-party as well. i did enable useStunTurn to true for both p2p and global configuration. but doesn’t seems to work. as soon as 3rd person join i see in my webrtc-internals becomes iceServers: []

can anyone give me some direction please??


#2

Is your coturn configured as a turns?
As jvb acts as a relay server for udp, we do not need coturn for those. We only need coturn for turns (tcp) connections which are better handled by coturn than jvb. That’s the reason those are filtered and only turns are used: https://github.com/jitsi/lib-jitsi-meet/blob/c2f269884a4991f1cee466367b98a095ace0b811/modules/xmpp/strophe.jingle.js#L364


#3

Umm I am using coturn with valid cert from certbot on port 443 is that what u mean?


#4

Do you have in your prosody config:
{ type = "turns", host = "my-turn.server.com", port = 443, transport = "tcp" }, ?


#5

@damencho first of all thanks for giving me the right direction. you are the best!! :smile:
ok i think i used a wrong mod_truncredentials module. I took a long and deep look at this post. then i replaced it with this mod and configured as you suggested there. Now seems to be working. Although I need to test more. will report back again if i face any difficulties again :nerd_face::nerd_face::nerd_face:


#6

Hi @Tanvir,
I met a samilar problem that is like yours.
I have copied mod_truncredentials to prosody modules but system still same error.
Pls help me how can resolve it.

Thanks,


#7

what is the error u get? what is the prosody version u r using?


#8

Hi @Tanvir,
Version Prosody 0.10.2
my error is when more than 3 participant join to meeting audio muted and camera muted.
And my error that i meet in Console is below:
Warning:
The Web Audio autoplay policy will be re-enabled in Chrome 70 (October 2018). Please check that your website is compatible with it. https://goo.gl/7K7WLu
(anonymous) @ LocalStatsCollector.js:22
app.bundle.min.js?v=3081:1 [modules/UI/videolayout/VideoLayout.js] <Object.changeUserAvatar>: Missed avatar update - no small video yet for undefined
a @ app.bundle.min.js?v=3081:1
Logger.js:125 [JitsiMeetJS.js] <Object.init>: Analytics disabled, disposing.
n @ Logger.js:125
Logger.js:125 [modules/statistics/AnalyticsAdapter.js] <e.value>: Disposing of analytics adapter.
n @ Logger.js:125
Logger.js:125 [modules/xmpp/strophe.jingle.js] <>: getting turn credentials failed <iq xmlns=​"jabber:​client" type=​"error" to=​"ebb6b22a-d405-4b27-a4fa-369ed4f4a31f@vc1.xxx.vn/​9dc10409-be6f-4999-b76e-59b8fc02a73a" from=​"vc1.xxx.vn" id=​"43897707-b1a6-45ca-bdb7-ed94792ad4ee:​sendIQ">​…​​
n @ Logger.js:125
Logger.js:125 [modules/xmpp/strophe.jingle.js] <>: is mod_turncredentials or similar installed?
n @ Logger.js:125
2Logger.js:125 [JitsiConference.js] <e.sendMessage>: Failed to send a ping request or response.
n @ Logger.js:125
62Logger.js:125 [JitsiConference.js] <e.sendMessage>: Failed to send a ping request or response.

Error:
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
n @ Logger.js:125
app.bundle.min.js?v=3081:1 Uncaught (in promise) DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
Logger.js:125 [JitsiMeetJS.js] <Object.getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD
n @ Logger.js:125
app.bundle.min.js?v=3081:1 Uncaught (in promise) DOMException: play() failed because the user didn’t interact with the document first. https://goo.gl/xX8pDD

Thanks,


Reinstall jitsi meet error audio muted and video muted
#9
  1. can I see the prosody log?
  2. can u show me, how u configured the prosody?
  3. can downgrade to prosody version 0.9.10 (reason I have faced a lot of pain in the past trying to use prosody 0.10.x so I gave up)
  4. go to chrome://webrtc-internals then create room with 3 ppl. see if u see the iceserver it will look something like this check ur stun server ip/address is there or not. if not there that means ur coturn is not configured properly. check to post i mentioned above very very carefully.
  5. I am not really sure why u get ping failed this is something @damencho can answer for u. I am still a beginner :sweat_smile::sweat_smile::sweat_smile:

but first do the 1- 4 see if u missed anything


#10

@Tanvir :blush: :blush: no problem.
@damencho Pls help me how to resolve it, Damian :slight_smile:

Thanks,