Use my own server for Jitsi meet conference

I have set up Jitsi on my own server on a domain like https://mydomain.com

Now, I plan to integrate Jitsi conference on Android and iOS through this url instead of meet.jit.si which is the default url.

I am invoking the following code in my Android application to make this possible:

     val serverURL: URL
        try {
            serverURL = URL(getString(R.string.jiitsi_url))
        } catch (e: MalformedURLException) {
            e.printStackTrace()
            throw RuntimeException("Invalid server URL!")
        }

        var userInfo = JitsiMeetUserInfo()
        val options = JitsiMeetConferenceOptions.Builder()
            .setServerURL(serverURL)
            .setWelcomePageEnabled(false)
            .setUserInfo(userInfo)
            .setRoom("1")
            .build()

        JitsiMeetActivity.launch(activity, options)

But, instead of going to the url defined in jiitsi_url above, it is going to http://meet.jit.si/1

Is there anything else that is required to point to my own Jitsi domain?

Thanks,
Gaurish

Hi Gaurish
mine working as follow, I created 2 instance of JitsiMeetConferenceOptions, one without room for default option. and the other one is for launch Activity.

      URL serverURL;
            try {
                serverURL = new URL("https://meet.mydomain.com");
            } catch (MalformedURLException e) {
                e.printStackTrace();
                throw new RuntimeException("Invalid server URL!");
            }

            JitsiMeetConferenceOptions.Builder builder = new 
            JitsiMeetConferenceOptions.Builder();
            builder.setServerURL(serverURL);
            builder.setWelcomePageEnabled(false);
            builder.setAudioMuted(false);
            builder.setAudioOnly(false);
            JitsiMeetConferenceOptions defaultOptions
                    = builder.build();

          JitsiMeet.setDefaultConferenceOptions(defaultOptions);

         JitsiMeetConferenceOptions options
                    = new JitsiMeetConferenceOptions.Builder()
                    .setServerURL(serverURL)
                    .setRoom(text)
                    .build();

           JitsiMeetActivity.launch(this, options);

but mine always return “bridge channel send: no opened channel” when point to my own server, but works finr when its default url https://meet.jit.si

Did anyone find a solution for this? I have the same issue in iOS App @saghul

I was able to resolve it by including server url in room property itself and did not use setServerURL, there seemed to be an issue with that. For example,

.setRoom("CONFERENCE_URL{intent.getStringExtra(CONFERENCE_ID)}")