USB Camera not found due to defective internal camera

Hi all,
my laptop has an internal camera, but it does not work at all. I have a USB (external) camera connected. If you test with APP Camera from Windows you can select both cameras. USB is showing a picture. Internal doesn’t as expected. Now the issue:
If you start Jitsi Meet a connection to conference is established. A box occure to select camera and microphone, but no selection was available. There was no chance to select USB-camera. Jitsi meet is blocked.
I could solve it as I deactivate the internal camera in Hardware manager of Windows. After start of jitsi meet the connection to conference is fully established. I had then the option to select internal mic or external mic. it works as expected.

If I using Zoom I haven’t discovered that issue. Internal malfunction camera was activated and zoom gave me a selection between internal and USB camera. Could you look in your code, that Jitsi circumvent that issue and come not in a blocking situation.

Hi Ralphi555,

If the camera is faulty, I would simply permanently disable it in Window’s Device Manager. Have done this at times myself, and not for Jitsi but other video conferencing systems.

Sorry, I don’t have control over the code in Jitsi.

But I do have control over which devices are enabled/disabled in my computer.

I have found that Web browsers, once you have confirmed to use a particular device (like the first time you connect to a site that uses a camera), the web browser does not always work well when trying to select another camera (or mic if that matters). I would suggest it is best practice to have the devices (microphones, speakers, cameras, etc) selected in Windows default settings before proceeding with a video conferencing system. That said, changing devices often works, just not always, at least in my experience. So I just reduce frustration, disable devices that don’t work, and set devices I want to use as the default devices, before starting any video conferencing or other programs which use hardware.

Hello GeorgeJitsi,

You are fully right. Disabling/Deactivating a device on windows level is the right way.

My point is that jitsi meet either give the user a hint that a faulty device is discovered and therefore it could not fully initialized, Or, the better way, it could fully initialized and user have to select the right device (camera in my case). My proposal is to make jitsi more user friendly.
My girlfriend is not experienced with computer and she was not able to join a jitsi-meeting due to the described situation.

For sure, I don’t know, if such a solution is easy or you can do it. I only noticed that zoom was able to fully initalization with two cameras (one faulty and another USB).

It could be that the faulty cam was initially selected and that selection is remembered by the browser. Your device selections are stored in your browser settings, not in Jitsi; so if you make a selection (either to use a particular device OR to reject the use of a device), that information is stored in your browser. You don’t experience the same thing with Zoom because you use the Zoom desktop app not the browser.

Go into your browser settings, look for permissions and you should be able to clear what ever choice(s) you previously made there.

Hello Freddie,

I understand the difference between Jitsi and Zoom. Your explanation sounds very reasonable. It’s a pity that the user cannot be informed from Jitsi. The issue has to be solved before using it (Windows / Browser). Thanks a lot for your explanation.

Apologies that this post will not answer your question, but I am curious why “do selection was available”, as I do get a selection of webcams to choose from when my PC has more than one camera attached.

Do you get a list of your web cameras in Chrome/Edge if you go to Privacy and security, Site Settings, Camera, (camera selection drop down) ?

In Jitsi, select More Actions (three dots), Settings, Devices tab, Camera (dropdown) you should also see a list of webcams if your browser detects them?