URL params are ignored -> Recording not working

Hi Folks,
I have a self-hosted jitsi-meet instance with recording and callIn/out and everything worked fine.
Yesterday I updated to the current stable version of jitsi-meet.
After the update the recorder stoped working, after quiet some testing I found that the URL params aren’t working.
(…/ctynrwlrk5#config.prejoinPageEnabled=false&config.requireDisplayName=false)
The Problem is caused by the recorder not being able to skip the prejoinPage.
So it can’t join the Meeting and leaves again without recording anything.
I have looked at all the configs etc. but there are no errors regarding the URL params.
Do I have to enable this feature somewhere now, or is something setup wrong?

Any help is appreciated.

Do you have modifications in the code?

Yes I modified the jitsi-meet-web package.
I clone the source and make my changes then I build it and create the debian packages.
I the install the web package over the existing install.
I build the packages new from a unchanged source and I have the same issues.
If I install jitsi with apt-get it works, so something I do must cause the error.
After some testing I found params like #config.startWithAudioMuted=true&config.startWithVideoMuted=true
work fine with my package but I can’t skip the prejoinPage.

Any Ideas what I could have done to cause the error.

That has changed.

Ahh thanks with the new name it works fine.
But why does the jibri use the old config parameter?
Thats why my recording isn’t working.
I updated to the newest version of jibri but ist still uses the old param.

(https://xxx.de/merprp#config.iAmRecorder=true&config.externalConnectUrl=null&config.startWithAudioMuted=true&config.startWithVideoMuted=true&interfaceConfig.APP_NAME="Jibri"&config.analytics.disabled=true&config.p2p.enabled=false&config.prejoinPageEnabled=false&config.requireDisplayName=false)

I am using jibri version “8.0-114-g20e233e-1”.