Urgent Help

I ran an update on Jitsi yesterday and we’ve come to use it today and it’s completely ignoring everything in the config file - so for example it’s ignoring the disableAudioLevels = true.

We made a few tweaks as the call quality isn’t good otherwise.

What has the update done, and how can I undo it?! I’m on stable build

Assuming you are using Debian/Ubuntu, you can download the old packages and install them with dpkg -i package.deb for every package that you upgraded.
This will effectively “downgrade” those packages.

To know exactly what changed (in the future), try using the etckeeper package, which puts your /etc directory under git.

it’s completely ignoring everything in the config file

Did you try looking at the config file from outside, i.e. by visiting this address with the web browser? https://example.com/config.js

You have to clear browser cache every time you do any changes to such file.

Thank you for your response, I’ve checked the /config.js as you suggested and I am getting the same as in my config files:

// Audio

// Disable measuring of audio levels.
disableAudioLevels: true,

Has this option been changed or disabled in the newest version?

what exactly is the newest version for you ? do you

  • run docker
  • run debian stable
  • run debian unstable
    and from what did your upgrade ? was it the N-1 version or did you upgrade a really oooold version ?