Upgrade of jitsi using helm charts broke

I have upgrade my jitsi helm charts from version 1.2.2 to 1.3.2, I have followed all the changes that are in newer version like clusterdomain setting, websockets and jvb public ip
I see this error in prosody

speakerstats.meet.jitsi:speakerstats_component               error	No muc_component specified. No muc to operate on!

But jicofo and jvb are able to authenticate

2s55ee61b7faa0                                              info	Authenticated as jvb@auth.meet.jitsi
c2s55ee61ae2ce0                                              info	Client connected
c2s55ee61ae2ce0                                              info	Stream encrypted (TLSv1.3 with TLS_AES_256_GCM_SHA384)
c2s55ee61ae2ce0                                              info	Authenticated as focus@auth.meet.jitsi

I dont see any error in jvb and jicofo logs

I am not able to start meeting
In console it says -
lib-jitsi-meet.min.js?v=6918:2 WebSocket connection to ‘wss://jitsi.xxxxxxxxxxxx’ failed:

<Object.getGlobalOnErrorHandler>: UnhandledError: Strophe: Websocket error [object Event] Script: null Line: null Column: null StackTrace: Error: Strophe: Websocket error [object Event]

I have enabled in websocket in values file

    ## Colibri (JVB signalling):
      enabled: false
    ## XMPP (Prosody signalling):
      enabled: true

Am i missing something or doing wrong ?
Thank you

I am running jitsi 8218 version in this issue, but if I change it to 7684 for all components, it works

Please open an issue on the Helm chart repo. It’s community maintained.

Thanks @saghul
But is it issue related to jitsi setup ?
I think its same issue as

It’s likely related to the Helm chart. It may need an update for the latest Docker images release.

Thanks @saghul
Is there any change in web config files from version 67XX to 82XX ?
Where I can find documentation or config for latest version ?
I am talking about config.js and interface-config.js where we set websocket url ?


Thanks @shawn
I have this config which overrides default config which we set according to out own environment
Can I use it same way in newer version too ? or how Can I test it?

/* eslint-enable no-unused-vars, no-var */

// Begin default config overrides.

if (!config.hasOwnProperty(‘hosts’)) config.hosts = {};

config.hosts.domain = ‘meet.jitsi’;
config.focusUserJid = ‘focus@auth.meet.jitsi’;

config.hosts.muc = ‘muc.meet.jitsi’;
config.bosh = ‘/http-bind’;
config.websocket = ‘wss://jitsi.something.com/xmpp-websocket’;

Note that the k8s setup uses our Docker images, so it’s likely that some env vars need to be adjusted, passed around. The config file is generated by Docker on container startup.

@saghul we are using module meeting_http and it fails on version 7577-2
I see package was removed

so if I want to use package luajwtjitsi 3.0-0, what is alternative for that ?
I get error when I run prosody container

modulemanager                                                error	Error initializing module 'meeting_http' on 'meet.jitsi': /usr/share/lua/5.4/prosody/util/startup.lua:202: module 'luajwtjitsi' not found:
	no field package.preload['luajwtjitsi']
	no file '/usr/local/share/lua/5.4/prosody/luajwtjitsi.lua'
	no file '/usr/local/share/lua/5.4/luajwtjitsi.lua'
	no file '/usr/local/share/lua/5.4/prosody/luajwtjitsi/init.lua'

I have no idea what tht module is. The luajwtjitsi module is now builtin and part of the jitsi installation. If that module depends on it they may need to update the require path.