Updating unstable currently broken on ubuntu 18.04

Hello one and all.

I’m trying to upgrade my jitsi installation.

root@meetings:/# apt list --upgradable
Listing... Done
jicofo/unstable 1.0-520-1 amd64 [upgradable from: 1.0-514-1]
jigasi/unstable 1.1-77-ga4b10f8-1 amd64 [upgradable from: 1.1-45-g7ca838d-1]
jitsi-meet/unstable 1.0.4181-1 all [upgradable from: 1.0.4153-1]
jitsi-meet-prosody/unstable 1.0.3796-1 all [upgradable from: 1.0.3775-1]
jitsi-meet-web/unstable 1.0.3796-1 all [upgradable from: 1.0.3775-1]
jitsi-meet-web-config/unstable 1.0.3796-1 all [upgradable from: 1.0.3775-1]
jitsi-videobridge/unstable 1130-1 amd64 [upgradable from: 1126-1]
root@meetings:/#

But i end up with a broken installation:

Errors were encountered while processing:
 jitsi-videobridge
 jitsi-meet
E: Sub-process /usr/bin/dpkg returned an error code (1)

Complete log:
https://nopaste.fluffycloud.de/?55c7d2a49aa11177#FZLXYJD21zkPCpoig1CMUZH3mRK9DED6QbkEQXpbaQnr

Someone has an idea what’s going on here?

cheers, t.

Sorry about that. Can you edit /var/lib/dpkg/info/jitsi-videobridge.postinst and add one line after set -e that is set -x and then execute:
sudo /var/lib/dpkg/info/jitsi-videobridge.postinst configure and share the output, mask any usernames or secrets in the output.

Are you using jetty to serve web or nginx?

  1. Must have jetty or Nginx on running status

  2. sudo apt purge jicofo

  3. sudo apt purge jitsi-videobridge

  4. sudo apt purge jitsi-meet-web-config

  5. sudo apt purge jitsi-meet-web

  6. sudo apt purge jitsi-meet

    If jitsi-meet-prosody cannot be removed, try this:
    1. sudo apt-get install --reinstall jitsi-meet-prosody
    2. sudo apt purge jitsi-meet-prosody
    3. sudo apt autoremove

  7. sudo apt purge prosody
    You can also get help from below
    https://github.com/jitsi/jitsi-meet/issues/1978

Nginx. Output from the postinstall script is coming up.

output:
https://nopaste.fluffycloud.de/?4f57326dfed5feeb#14S5vxgoxQNCZqA2fXojn41UKWgj2goGWjdNa2KuUPSb

Hi @Raj_Yadav was this advise for me?

Hum, I think I know what is wrong. Here is a workaround:

  • edit /etc/jitsi/videobridge/config and make sure JVB_OPTS contains: --apis=,
  • like JVB_OPTS="--apis=,"
    Then run upgrade again, I will create a fix for those.

Yes ,Because of i have been resolving such issue by above steps .

@Raj_Yadav I just wanted to note two things. First such issues should be reported so we can fix them and secondly when giving advices for purge, make sure you warn people that all their settings will be deleted and if needed to make a backup of the folders that will be deleted.
Thanks.

And @himbeere thanks for the report.

1 Like

That worked @damencho. Thanks again. :slight_smile:

Side note. On this machine i had to disable the jitsi repo before updating a pending nginx update. I got this:

https://nopaste.fluffycloud.de/?9384915108002557#DYh73wk7vnEyKKE4B7M7tSPTyaykMmp9XMZagGV7rWcM

I guess jitsi and nginx update together in one batch does not compute?
After the nginx update i reenabled the jitsi repo and ran into the postint script problem.

cheers, t.

Hum, interesting … thanks for sharing.

Just tested jigasi. Is it possible we got back the 30s hangup problem?

2020-01-23 11:08:54.955 INFO: [230] org.jitsi.jigasi.SipGatewaySession.handleCallState().1138 [ctx=15797776975481013641544] SIP call ended: CallPeerChangeEvent: type=CallPeerStatusChange oldV=net.java.sip.communicator.service.protocol.CallPeerState:Connected newV=net.java.sip.communicator.service.protocol.CallPeerState:Disconnected for peer=501 <501@87.98.245.213>;status=Disconnected

net.java.sip.communicator.impl.protocol.sip.SKIP_REINVITE_ON_FOCUS_CHANGE_PROP=true

is still there.

Here are the PRs for jvb and jvb2:


About jigasi, if you have that setting I doubt it is that, you should see the setting in the logs when starting up.
I even added it by default:

You are right @damencho, the second test was successfull. False alarm. Sorry. Thanks for the quick fixes by the way.

cheers, t.