Updating interface_config.js

Hi all,

I am new to jitsi-meet.I am trying to update the interface_config js files but changes i have done is not reflecting when i run it.
What i have done is donwload Jitis-meet code from github.
changed inteface_config.js file. just update a flag from true to false.
run npm install.
and make dev.
It runs the jitsi-meet on localhost.
But the configuration changes whatever i made in interface_config file never reflects while debugging at localhost.
Can someone please let me know how can i update it?

do you got the right “interface_config.js”?
in your nginx root path (standard path by the tutorial for manual installation: “/srv/jitsi-meet”)

check the page source-code in browser, when you open your jitsi page.
does it serve/include the right “interface_config.js” with your changes in it?
(source-code start at line ~687: var interfaceConfig = { … } )

try to change or enable/disable simple, visible things like

APP_NAME (== browser tab gets the name by it)
SHOW_JITSI_WATERMARK (== jitsi logo on top left corner)
SHOW_WATERMARK_FOR_GUESTS

otherwise, the build process (npm install & make) doesn’t affect the “interface_config.js”,
more or less it just builds the javascript libraries and outputs them to “/libs/” (if i got it right).

tried changing the
APP_NAME (== browser tab gets the name by it)
SHOW_JITSI_WATERMARK (== jitsi logo on top left corner)
SHOW_WATERMARK_FOR_GUESTS

but none reflects.in browser.
I checked whole system and found only 2 places where this file is . change on both location and still no success. our main WEBPACK_DEV_SERVER_PROXY_TARGET is at different location than mine personal laptop.
So i am not sure if it is picking interface_config from there or my machine.

“it is picking from there” yes … not your own machine

take a look at your webserver … where its running at, whats the set root path?
there should be the jitsi meet web files (index.html, interface_config.js, …)
and there you have to make changes :wink: