Updated - No longer limiting incoming FPS

Hello,

I recently ran an update and some of my audio and video settings in config.js stopped working. I figured out what happened in the audio. I was using the settings that enable HD audio, but the update overrides any disableAEC: TRUE. I turned off the stereo and maxopusbitrate, so AEC is back on.

However, it seems Jitsi is no longer limiting FPS for incoming streams in p2p, though it does limit my fps to 15. For example, on tests at home my sending stream was 15 fps (m1 Mac, Edge), but I was receiving 30fps (older Mac, Chrome). I tried variations on the setting, but nothing seemed to change and it was confirmed at webrtc-internals.

If anyone can let me know if there’s any other settings I should adjust, or if something is wrong, I would appreciate it. Note, I’m not a dev, just a music teacher.

// Audio
disableAP: false, // disable ??
disableAEC: false, // disable echo suppression and cancellation
disableNS: true, // disable noise suppression
disableAGC: true, // disable automatic gain control
disableHPF: true, // disable high pass filter??? (no lower-than-speech sounds)
// stereo: true, // stereo sound

    // Disable measuring of audio levels.
     disableAudioLevels: true,
    // audioLevelsInterval: 200,

    // Enabling this will run the lib-jitsi-meet no audio detection module which
    // will notify the user if the current selected microphone has no audio
    // input and will suggest another valid device if one is present.
    enableNoAudioDetection: false,

    // Enabling this will show a "Save Logs" link in the GSM popover that can be
    // used to collect debug information (XMPP IQs, SDP offer/answer cycles)
    // about the call.
    // enableSaveLogs: false,

    // Enabling this will run the lib-jitsi-meet noise detection module which will
    // notify the user if there is noise, other than voice, coming from the current
    // selected microphone. The purpose it to let the user know that the input could
    // be potentially unpleasant for other meeting participants.
    enableNoisyMicDetection: false,

    // Start the conference in audio only mode (no video is being received nor
    // sent).
    // startAudioOnly: false,

    // Every participant after the Nth will start audio muted.
    // startAudioMuted: 10,

    // Start calls with audio muted. Unlike the option above, this one is only
    // applied locally. FIXME: having these 2 options is confusing.
    // startWithAudioMuted: false,

    // Enabling it (with #params) will disable local audio output of remote
    // participants and to enable it back a reload is needed.
    // startSilent: false

    // Sets the preferred target bitrate for the Opus audio codec by setting its
    // 'maxaveragebitrate' parameter. Currently not available in p2p mode.
    // Valid values are in the range 6000 to 510000
   //  opusMaxAverageBitrate: 510000,

    // Enables support for opus-red (redundancy for Opus).
     enableOpusRed: true,

    // Video

    // Sets the preferred resolution (height) for local video. Defaults to 720.
    resolution: 480,
    maxFps: 15,

    // How many participants while in the tile view mode, before the receiving video quality is reduced from HD to SD.
    // Use -1 to disable.
    // maxFullResolutionParticipants: 2,

    // w3c spec-compliant video constraints to use for video capture. Currently
    // used by browsers that return true from lib-jitsi-meet's
    // util#browser#usesNewGumFlow. The constraints are independent from
    // this config's resolution value. Defaults to requesting an ideal
    // resolution of 720p.
     constraints: {
         video: {
	     aspectRatio: 16 / 9,
             height: {
                 ideal: 480,
                 max: 480,
                 min: 240
             },
	    frameRate:{
		max: 15
		}
         }
     },

    // Enable / disable simulcast support.
     disableSimulcast: true,

    // Enable / disable layer suspension.  If enabled, endpoints whose HD
    // layers are not in use will be suspended (no longer sent) until they
    // are requested again.
     enableLayerSuspension: false,

Does anyone have any insight as how to re-enable max fps setting?

Thankfully resolution is still limited, so my calls remain mostly stable.