Unwanted immediate redirection to random room

Hello Jitsi-Fellows,

I’m new to Jitsi and I’m not an english native-speaker, so please excuse, if my english is not as precise as it should be for a correct fault description.

I’m trying to get it running on ubuntu 20.04 LTS on a bare metal server connected through ssh. Nearly everything worked fine until yesterday.

While I tried to activate the prejoin-page, it obviously happend, that I made some kind of mistake and now I’m getting immediately redirected to a random room passing the welcome page.

Now I’m struggeling finding my last changes, that caused it.

Until yesterday worked:

  • some changes to the layout
  • authentication for the opener of the conference and anonymous login with request for the nickname
  • P2P-connection actived and deactivated
  • 3 member conference, so that the rendering had to be done on the server
  • muting audio and video, when the second member enters the conference
  • reducing of the video resolution
  • increasing ram-usage of the server

If I unterstand it the concept right, the problem cound be in prosody. I rechecked the logfiles, different configuration files for missing commas at the end of the lines and all the modifications I made.

After more than 6 hours of trouble-shooting and searching in different communities and search-engines I have hope for some support or suggestions from the community.

I can’t paist logfiles here directly as the system is not connected to this computer, but i it helps I can transcribe it from one monitor to the other.

Might there be some help? Thanks a lot in advance!

cri

Did you disable enableWelcomePage?

Ok, that was an embarrassing beginner’s mistake … obviously I mixed up the prejoin page and the welcome page.

Thank’s a lot for this quick answer! You’ll be my hero for the weekend and I’ll include you in my prayers tonight! You saved my weekend and my hollidays!

Well … it seems that during my trouble-shooting I misconfigured something else as well:

in a session with two computers only two videos can be shown: Wether both cameras only on one computer or the same one camera on both computers

[Edit: … and after deactivating and reactiving one camera now on one side both videos are availible, but still not on both computers. I’m still revewing my config files … ]

Any idea to this as well, before I’ll search again as long as before or opeing a new thread?

I hope, later I can give something back to this forum and their users.

If someone is reading this second incident as well:

In the file /etc/jitsi/jicofo/config I commented out the line after the following comment:

# extra options to pass the jicofo daemon
JICOFO_OPTS=""

Even there’s nothing between the two " " , after removing the # and reloading all the services I had both camera videos again on both computers (p2p is <enabled: false,> in /etc/jitsi/meet/domain-config.js for testing the videobridge instead of using the direct connection)

[Edit: If someone has a hint, how I can create the text formatting like emrah did in his previous posting, I’ll be happy for some comments]

[Edit2: Forget the former written soluten. Again only on one computer both camera-streams are viewable. The other computer has only his own video shown. I’ll go on searching and use an own thread for further questions or solutions.]

Use either of the highlighted on the toolbar to format your text:

Screen Shot 2021-03-01 at 9.45.26 PM

Thanks! I’ll use it!

Is this also the way to get a formatted block like ermah did in his answer?

How can I move this second topic in a seperate thread? Or do I need to copy it and leave this here?

Just create a new thread. Reference this post for guidance: