UNMET PEER DEPENDENCY on npm install


#1

Dear developers,
I have trouble “installing” jitsi-meet sources after successful checkout (version [057b300] today on master) into a clean directory. The development system runs on Ubuntu 18.04.1 LTS, npm 3.5.2, nodejs 8.10.0.
Everything has been installed as instructed here: https://github.com/jitsi/jitsi-meet#building-the-sources
Errors occour during the execution of npm install

│ ├── UNMET PEER DEPENDENCY react@^16.4.0
│ ├── UNMET PEER DEPENDENCY react-dom@^16.4.2
│ └── UNMET PEER DEPENDENCY styled-components@^3.2.6

It seems that there are wrong dependencies.
Should I try another version? Which one is considered stable enough to include latest fixes? Or is not Jitsi related problem?
Thanks!


#2

thats just a suggestion from npm. u can ignore that.


#3

Thanks for quick reply, I’ve created the required react modules for my app now, but extending JitsiMeetActivity the activity starts, but when I tap on the screen no Jitsi icons are displayed !?
What am I doing wrong?
Differently, if I use the JitsiMeetView way all seems to work fine, but all options labels are in english, is there a method to change the language?
Thanks again!