Unmet dependencies on fresh Ubuntu 18.04.1


#1

Hi,

I installed a brand new (bare) ubuntu 18.04.1

I followed the install instructions as mentioned here on the site to the letter (I’m not an Ubuntu specialist…).

All entered command end up with either no error or OK

But every time I end up with an error when executing “apt-get -y install jitsi-meet”

The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (=1.0.3081-1) but it is not going to be installed
etc…

I restarted the complete server + jitsi install about 5 times from scratch, but it always ends with this error…
I installed Java8, but this doens’t change anything

So… Help …


#2

Check this part from the quick install:

Also note that a recent default Ubuntu installation has only the main repository enabled, and Jitsi Meet needs packages from universe. 

#3

Hi,

I have changed the repository entries to universe, as explained. (and apt-get updated)

Where I initially had 3 or 4 errors, I’m now left with only one:

The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.3081-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


#4

Can you try apt install prosody? Does it work? Did you do apt update after after adding universe repo? You’ve added it, not replace the main one, right?


#5

Ouch… Replaced in stead of adding… Will correct thuis net monday at the office

EDIT: couldn’t wait :slight_smile: Remote config from home… Copying + modifying the repository entries solved the problem.

Thanks for the quick and accurate help.