Unity Webrtc and Jitsi

I’m looking forward to conncet my Unity WebRTC app with Jitsi Videobridge, there is a tutorial or guide to learn how to connect any webrtc app to the videobridge?

Hi and welcome. No there is no such tutorial.
You can always start by installing jitsi-meet and see how it works. Basically you need a component that will be orchestrating the video conferencing for this we use a component called jicofo which opens channels with videobridge and uses those channels to send invitations through xmpp to the clients.
There is also REST API for the bridge where you can do the same operations …

Thanks so much for the answer. I already installed jicofo and videobrige but had problems with the meet and the jitsi-meet-prosody (–configure). Do I need the entire suit to make my architecture work?

It is easier to start from something working … You had followed the https://jitsi.org/qi, right? If that is the case I’m interested to understand what was the problem with jitsi-meet-prosody, OS and version?

I’m using Ubuntu 16.04 and the exact error is on the image. Again, thanks a lot

What prosody version is there on 16.04 … ? Maybe it is too old and we broke the support for those at some point, yeah not sure what is the exact problem.
You can try restarting prosody and see whether it succeeds, if not using the information from the logs you may fix the problem …

I change my linux to 18.04, but got the same problem.

I’m constantly testing on 18.04 without any problem.
How do you install it:

echo 'deb https://download.jitsi.org stable/' >> /etc/apt/sources.list.d/jitsi-stable.list
wget -qO -  https://download.jitsi.org/jitsi-key.gpg.key | apt-key add -
apt-get update
apt-get -y install jitsi-meet

?
By any chance you use ubuntu-minimal? There are some issues we need to fix in order to make it work with -minimal.

Understood, the problem must be the hostname. I’ll try now, thank you

Standard ubuntu or minimal?

I’ve tried both.

It is supposed to fail on minimal and work on the standard one. I will give a try virtualbox today.

@dvd_rodriguez I just downloaded ubuntu-server from the official site, put it in virtualbox and installed jitsi-meet successfully with the commands I listed above.
Are you putting as a hostname localhost or nothing as input which will default to localhost? Maybe you have virtualhost localhost already defined in prosody and that is the problem.
You should input there the DNS name you will use to access that deployment, which normally is not localhost.

I did the exact thing that you did, and still getting the same error.

Did you fill anything for the host name?

No, I leaved empty.

That’s your problem, as it then defaults to localhost and prosody has a conflicting virtualhost.
There you need to enter the value you will input in the browser to access your deployment, not entering anything is not a working scenario we will update the packaging to avoid that in the future.

Actually I leave it empty just the last time now I did it again (empty) and it seems to work, when I input on te browser https://localhost a jitsi page come out.