Unfrtunately, something went wrong. We're trying to fix this. Reconnecting in 29 sec

Dear support,

we are having a problem on ->unfortunately something went wrong, we are trying to fix this. Reconnecting in 29 sec. do you have any advice?

Our OS Ubuntu 16.04.6 LTS

Warm Regard,
Phalla

Do you have secure domain implemented? Looks like you do. If so, did the Moderator authenticate successfully?

This is problem with jicofo entering the meeting.

How to fix it?

Check your jicofo logs

We checked log jicofo It show “Connection refused”

root@meet:~# tail /var/log/jitsi/jicofo.log -f
at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:607)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)
… 11 more
Jicofo 2020-10-14 09:12:24.662 SEVERE: [40] org.jitsi.xmpp.component.ComponentBase.log() Failed to send ping
java.lang.NullPointerException
at org.xmpp.component.AbstractComponent.send(AbstractComponent.java:925)
at org.jitsi.xmpp.component.ComponentBase.access$400(ComponentBase.java:36)
at org.jitsi.xmpp.component.ComponentBase$PingTask.run(ComponentBase.java:577)
at java.util.TimerThread.mainLoop(Timer.java:555)
at java.util.TimerThread.run(Timer.java:505)
Jicofo 2020-10-14 09:12:25.051 SEVERE: [41] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Connection refused (Connection refused), host:meet.sunshinecity.com.hk, port:5347
org.xmpp.component.ComponentException: java.net.ConnectException: Connection refused (Connection refused)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:296)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:242)
at org.jivesoftware.whack.ExternalComponentManager.addComponent(ExternalComponentManager.java:222)
at org.jitsi.meet.ComponentMain.lambda$getConnectCallable$0(ComponentMain.java:286)
at org.jitsi.retry.RetryStrategy$TaskRunner.run(RetryStrategy.java:193)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.net.ConnectException: Connection refused (Connection refused)
at java.net.PlainSocketImpl.socketConnect(Native Method)
at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)
at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)
at java.net.Socket.connect(Socket.java:607)
at org.jivesoftware.whack.ExternalComponent.connect(ExternalComponent.java:174)
… 11 more

Is prosody on the same machine or not. It fails ro connect to this host and this port.

Yes, prosody the same machine host:meet.x.x.x,
The machine has service:

  • prosody
  • jitsi-videobridge
  • jicofo
  • nginx

So in your etc jitsi jicofo config set host to localhost, restart jicofo and test again.

Thanks let us try

We changed set host to localhost "JICOFO_HOST=localhost
"
But still error

netstat -anp| grep lua
What does it show, is prosody listening on that port on localhost?

tcp 0 0 0.0.0.0:5280 0.0.0.0:* LISTEN 20074/lua5.1
tcp 0 0 0.0.0.0:5281 0.0.0.0:* LISTEN 20074/lua5.1
tcp 0 0 203.1.18.1:5347 0.0.0.0:* LISTEN 20074/lua5.1
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN 20074/lua5.1
tcp 0 0 127.0.0.1:5582 0.0.0.0:* LISTEN 20074/lua5.1
tcp 0 0 0.0.0.0:5269 0.0.0.0:* LISTEN 20074/lua5.1
tcp 0 0 127.0.0.1:5222 127.0.0.1:48576 ESTABLISHED 20074/lua5.1
tcp 0 0 127.0.0.1:5280 127.0.0.1:35632 ESTABLISHED 20074/lua5.1
tcp6 0 0 :::5280 :::* LISTEN 20074/lua5.1
tcp6 0 0 :::5281 :::* LISTEN 20074/lua5.1
tcp6 0 0 :::5222 :::* LISTEN 20074/lua5.1
tcp6 0 0 ::1:5582 :::* LISTEN 20074/lua5.1
tcp6 0 0 :::5269 :::* LISTEN 20074/lua5.1
tcp6 0 0 ::1:5280 ::1:38230 ESTABLISHED 20074/lua5.1
unix 2 DGRAM 1054115 20074/lua5.1

Try this IP address and make sure your firewall is not blocking it.

You can control where prosody listens with component_interface = "192.168.0.10" https://prosody.im/doc/components

We checked prosody.cfg.lua it correct

component_ports = { 5347 }
component_interface = { “203.1.18.1” }

So this should be in your jicofo config instead of localhost and the port should not be blocked by fw.
If you are not connecting any other component there you can leave it on localhost and leave jicofo to connect to localhost.

You mean that change IP 203.1.18.1 to 127.0.0.1?

component_ports = { 5347 }
component_interface = { “127.0.0.1” }

Yep that will work restart prosody and jicofo and try

Thank you, now It works, but when we join meeting video call. It shows the same error. could you help about this problem.

@damencho please help us advise.
now we have a problem with the database mysql. we cannot access to database.
root@meet:~# mysql -uroot p
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)
root@meet:~# mysql -uroot p
ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: NO)

and we check service mysql is active normal.