"Unfortunately something went wrong" when second user joins

When a second user joins, both users see “Unfortunately something went wrong”, and the browsers try to re-connect.

I am getting below error in the console,

I have installed the latest JITSI meet on Ubuntu 18.04 LTS.

Firewall Status:
$ sudo ufw status verbose

Status: active
Logging: on (low)
Default: deny (incoming), allow (outgoing), disabled (routed)
New profiles: skip

To                         Action      From
--                         ------      ----
80/tcp                     ALLOW IN    Anywhere                  
443/tcp                    ALLOW IN    Anywhere                  
4443/tcp                   ALLOW IN    Anywhere                  
10000/udp                  ALLOW IN    Anywhere                  
22/tcp                     ALLOW IN    Anywhere                  
80/tcp (v6)                ALLOW IN    Anywhere (v6)             
443/tcp (v6)               ALLOW IN    Anywhere (v6)             
4443/tcp (v6)              ALLOW IN    Anywhere (v6)             
10000/udp (v6)             ALLOW IN    Anywhere (v6)             
22/tcp (v6)                ALLOW IN    Anywhere (v6)             

I tried this (as mentioned here: https://github.com/jitsi/jitsi-meet/issues/5696),

sudo apt-get purge jigasi jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jicofo jitsi-videobridge2
sudo apt-get purge prosody
sudo apt autoremove
sudo apt-get -y install jitsi-meet
sudo /usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh

Didn’t solve the problem.

Result of ‘dpkg -l | grep jitsi’

ii  jitsi-meet                             2.0.4627-1                                  all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody                     1.0.4127-1                                  all          Prosody configuration for Jitsi Meet
ii  jitsi-meet-turnserver                  1.0.4127-1                                  all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                         1.0.4127-1                                  all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config                  1.0.4127-1                                  all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2                     2.1-202-g5f9377b9-1                         all          WebRTC compatible Selective Forwarding Unit (SFU)

Can you paste the output?

curl ifconfig.me

ip a

host YOUR.HOST.ADDRESS

Hi @emrah

$ curl ifconfig.me
52.0.113.32

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 9001 qdisc mq state UP group default qlen 1000
    link/ether 0e:b5:07:2c:84:ed brd ff:ff:ff:ff:ff:ff
    inet 172.31.22.247/20 brd 172.31.31.255 scope global dynamic eth0
       valid_lft 3410sec preferred_lft 3410sec
    inet6 fe80::cb5:7ff:fe2c:84ed/64 scope link 
       valid_lft forever preferred_lft forever

$ host YOUR.HOST.ADDRESS

I have not set it with any domain/subdomain yet. I am currently accessing it using the IP only.

Didn’t you set a hostname during the installation? If yes, the clients should use this hostname, not IP…

And are your clients in the same network or from the internet? If in the same network, you should set the NAT_HARVESTER setting in the /etc/jitsi/videobridge/sip-communicator.properties file.

Hi @emrah,

  1. I set the hostname as my IP during the installation.
  2. My clients are from the internet. Everyone is accessing the installed JITSI by hitting the URL: https://52.0.113.32/

Can you try to set the NAT_HARVESTER?

Add these two lines to /etc/jitsi/videobridge/sip-communicator.properties and reboot

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=172.31.22.247
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=52.0.113.32

Your public IP?
52.0.113.32 ?

Yes. Public IP.

I added these two lines to /etc/jitsi/videobridge/sip-communicator.properties

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=172.31.22.247
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=52.0.113.32

and restarted the videobridge and other services,

$ sudo systemctl restart prosody
$ sudo systemctl restart jicofo
$ sudo systemctl restart jitsi-videobridge2

But still getting the same issue.

I didn’t do any installation using an IP address before. Maybe it’s related in this.
I have no more idea.

Okay. Thanks, @emrah.

@damencho can you please help with this.

Hi All,

I uninstalled the JITSI and tried the fresh install using the article: https://jitsi.github.io/handbook/docs/devops-guide/devops-guide-quickstart

I have also set a domain and advance configuration but still getting the same issue.

I also tried the solution posted by @kitsis here: Room crashes when anyone trys to join
But still, it’s not working, getting the below error when second users joins the call.

cc: @damencho @emrah

Hi @VishalKale, Where you able to find a solution for this?