"Unfortunately something went wrong we're trying to fix this" right after install


#1

hi

did the install as written on git with the debian packages. everything went fine. if i log into the webpage it seems to run fine, but when somebody else joins the channel both get this “Unfortunately something went wrong we’re trying to fix this” message and then the page reloads

looked at the logs and the *.err logs where all empty.
but in the jvb.log i have lots of entries like that :

…/jitsi/jvb.log:JVB 2018-09-09 11:50:32.251 SCHWERWIEGEND: [568496] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.
…/jitsi/jvb.log:JVB 2018-09-09 11:53:12.252 SCHWERWIEGEND: [569184] org.ice4j.socket.MergingDatagramSocket.log() Cannot find socket to remove.

could that be my problem? i dont know whis software writes this file… i tried to find out …

root@kvm06:/var/log/jitsi# lsof |grep jvb.log
java 2164 jvb 1w REG 253,0 39254782 2667 /var/log/jitsi/jvb.log
java 2164 jvb 2w REG 253,0 39254782 2667 /var/log/jitsi/jvb.log
java 2164 2169 jvb 1w REG 253,0 39253210 2667 /var/log/jitsi/jvb.log

root@kvm06:/var/log/jitsi# ps 2164
PID TTY STAT TIME COMMAND
2164 ? Sl 7:32 java -Xmx3072m -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp -Djava.library.path=/usr/share/jitsi-videobridge/lib/native/linux-64 -Dnet.java.s

so its the videobridge ?

any help would be really greate…


#2

oh and another question …

in the /etc/jitsi/videobridge/config file i have this section :

sets the hostname of the XMPP server (default: domain if set, localhost otherwise)

JVB_HOST=

sets the port of the XMPP server (default: 5275)

JVB_PORT=5347

so its fine that JVB_HOST is set to “nothing” and why is JVB_PORT set to 5337 if 5275 is default?

regards


#3

Check your browser console logs when this happens, is it videobridgeNotFound error? If that is the case, delete videobridge logs in /var/log/jitsi, restart jvb and check again the logs, do you see any error?


#4

strange, the moment i wanted to do so, it worked. nothing changed on my side.
bout the videobridgeNotFound thing… is there something i could check so i add that to my monitoring and restart the bridge whenever its not avalible…


#5

If you want monitoring then you better do a health checks requests to jicofo and you can also specify jicofo to check jvb: https://github.com/jitsi/jicofo/blob/master/doc/health-checks.md.
Just doing http://localhost:8888/about/health?list_jvb=true.


#6

oh didnt knew that. thanks a lot for the advice.