"Unfortunately something went wrong" error

Hello,

I set up Jitsi server on VPS (not behind NAT). It works properly from my home network, but any session crashes only from my office network.

OS: Ubuntu 18.04

Chromium console:

[modules/RTC/BridgeChannel.js] <l._send>:  Bridge Channel send: no opened channel.
-snip-
[conference.js] <ee._onConferenceFailed>:  CONFERENCE FAILED: conference.iceFailed
-snip-
[modules/RTC/BridgeChannel.js] <RTCDataChannel.e.onerror>:  Channel error: undefined

/var/log/jitsi.jvb.log:

INFO: [356] [confId=5526705625526add gid=ffe688 stats_id=Trevor-dXD conf_name=xxx ufrag=2i6i41e9s3786c epId=25367fb2 local_ufrag=2i6i41e9s3786c] ConnectivityCheckClient.processTimeout#857: timeout for pair: <VPS-IP>:10000/udp/host -> <myOffice-IP>:36924/udp/host (stream-25367fb2.RTP), failing.
-snip-
INFO: [173] [confId=5526705625526add gid=ffe688 stats_id=Trevor-dXD conf_name=xxx ufrag=6ena51e9s37873 epId=3ca2d1f8 local_ufrag=6ena51e9s37873] ConnectivityCheckClient.processTimeout#857: timeout for pair: <VPS-IP>:10000/udp/host -> <myOffice-IP>:49833/udp/host (stream-3ca2d1f8.RTP), failing.

Can anyone help me?

I have the same issue as you.

I’m very disappointed with Jitsi.

I had the same issue and no solution yet. But, I tried to connect to internet through third party VPN then the jitsi meeting works!
I do not know what is the link between the vpn and this issue!
Maybe this info get some idea.

Does a conference with 3 or more participants work while connecting from the home network? Not P2P…

Is port 10000 UDP open?

Yes. A conference works fine not only with 2 participants (P2P) but also with more than 2 from my home network.

In the case of my office network, only one person conference works fine. But when the second person joins the meeting, it crashes in about 10 seconds.

Yes.

$ sudo ufw status
To                         Action      From
--                         ------      ----
80/tcp                     ALLOW       Anywhere
443/tcp                    ALLOW       Anywhere
4443/tcp                   ALLOW       Anywhere
xxxx/tcp                   ALLOW       Anywhere <- SSH port
10000/udp                  ALLOW       Anywhere
80/tcp (v6)                ALLOW       Anywhere (v6)
443/tcp (v6)               ALLOW       Anywhere (v6)
4443/tcp (v6)              ALLOW       Anywhere (v6)
10000/udp (v6)             ALLOW       Anywhere (v6)
xxxx/tcp (v6)              ALLOW       Anywhere (v6)  <- SSH port

Thank you for your information about your workaround. I’ll try it.

Thank you for your comment. It’s reassuring to know that it’s not just a problem for my office network. For me, Jitsi meeting is wonderful software and I’d like to find some kind of solution.

@yasser It works perfectly through VPN! Thank you for your advice.

But it’s a just workaround…? :thinking:

Do you use your own SSL?

I followed the self-hosting guide and used Let’s Encrypt SSL Certificate.

Hi, I used my own SSL certificate and I having the same problema?, there is any issue with that?

Hi oshie,

You can try my method.
Step 1: sudo apt purge jigasi jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jicofo jitsi-videobridge2.

Step 2: hostnamectl set-hostname yourdomain (example: abc.net.us)

Step 3:
sudo ufw allow OpenSSH
sudo ufw allow http
sudo ufw allow https
sudo ufw allow 10000:20000/udp
sudo ufw enable

Step 4:
Sudo apt system
Sudo apt upgrade –y && sudo shutdown –r now

Step 5
sudo apt install -y openjdk-8-jre-headless

echo “JAVA_HOME=$(readlink -f /usr/bin/java | sed “s:bin/java::”)” | sudo tee -a /etc/profile source /etc/profile

Step 6:
sudo apt install -y nginx
sudo systemctl start nginx.service
sudo systemctl enable nginx.service

Step 7
wget -qO - https://download.jitsi.org/jitsi-key.gpg.key | sudo apt-key add –

sudo sh -c “echo ‘deb https://download.jitsi.org stable/’ > /etc/apt/sources.list.d/jitsi-stable.list”

sudo apt update –y

sudo apt install -y jitsi-meet

input your domainname if jitsi ask you. If not, it is the same the first installation.

Choice “I want to use my certificate”

Step 7: Update SSL key and SSL crt to folder and verify SSL install success.

That’s all.

Try and give me feedback.

Thanks.

I tried as you said and this happens, after even two clients on chrome browser it disconnects.

Logger.js:154 2020-06-05T21:42:07.218Z [modules/e2eping/e2eping.js] <h.stop>: Stopping e2eping

Logger.js:154 2020-06-05T21:42:07.224Z [modules/xmpp/ChatRoom.js] <_.doLeave>: do leave a@conference.mely.com.np/ec411c22

Logger.js:154 2020-06-05T21:42:07.273Z [modules/RTC/TraceablePeerConnection.js] <A.close>: Closing TPC[1,p2p:false]...

Logger.js:154 2020-06-05T21:42:07.326Z [modules/RTC/TraceablePeerConnection.js] <A.close>: Closing TPC[2,p2p:true]...

Logger.js:154 2020-06-05T21:42:07.352Z [conference.js] <a.<anonymous>>: My role changed, new role: moderator

Logger.js:154 2020-06-05T21:42:07.357Z [modules/UI/videolayout/VideoLayout.js] <Object.changeUserAvatar>: Missed avatar update - no small video yet for local

Logger.js:154 2020-06-05T21:42:07.361Z [modules/UI/videolayout/VideoLayout.js] <Object.changeUserAvatar>: Missed avatar update - no small video yet for ec411c22

Logger.js:154 2020-06-05T21:42:07.362Z [modules/xmpp/strophe.jingle.js] <g.onJingle>: on jingle source-remove from a@conference.mely.com.np/focus

1. <iq xmlns=​"jabber:​client" type=​"set" to=​"ec411c22-928a-44d9-98ae-58f6d7fad934@mely.com.np/​b5d20d5b-705c-4bf2-8fd2-8c8710df3385" from=​"a@conference.mely.com.np/​focus" id=​"ZWM0MTFjMjItOTI4YS00NGQ5LTk4YWUtNThmNmQ3ZmFkOTM0QG1lbHkuY29tLm5wL2I1ZDIwZDViLTcwNWMtNGJmMi04ZmQyLThjODcxMGRmMzM4NQBNZlp2eS05MDMA4T5MkSGiX8omcwgcmbyalA==">​…​</iq>​

Logger.js:154 2020-06-05T21:42:07.367Z [modules/UI/videolayout/VideoLayout.js] <Object.removeParticipantContainer>: No remote video for a9d19e91

Logger.js:154 2020-06-05T21:42:07.368Z [conference.js] <a.<anonymous>>: USER a9d19e91 LEFT:

1. u {_jid: "a@conference.mely.com.np/a9d19e91", _id: "a9d19e91", _conference: se, _displayName: undefined, _supportsDTMF: false, …}

Logger.js:154 2020-06-05T21:42:07.370Z [modules/xmpp/moderator.js] <u.onMucMemberLeft>: Someone left is it focus ? a@conference.mely.com.np/a9d19e91

Logger.js:154 2020-06-05T21:42:07.378Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe disconnecting: 20104.720000003

Logger.js:154 2020-06-05T21:42:07.381Z [modules/xmpp/strophe.util.js] <Object.r.Strophe.log>: Strophe: Disconnect was called because: undefined

Logger.js:154 2020-06-05T21:42:07.406Z [modules/RTC/BridgeChannel.js] <RTCDataChannel.e.onerror>: Channel error: undefined

Logger.js:154 2020-06-05T21:42:07.408Z [modules/RTC/BridgeChannel.js] <RTCDataChannel.e.onclose>: Channel closed by client

Logger.js:154 2020-06-05T21:42:07.415Z [modules/xmpp/xmpp.js] <A.connectionHandler>: (TIME) Strophe disconnected: 20141.424999994342

Logger.js:154 2020-06-05T21:42:07.416Z [modules/xmpp/strophe.ping.js] <p.stopInterval>: Ping interval cleared

Logger.js:154 2020-06-05T21:42:09.092Z [features/base/storage] <Object.persistState>: redux state persisted. 27974fee285de6413e11ca4dabd64447 -> d864e2aa6d41d3dab742c0c41772d022

Please also open this port on your hard firewall

1 Like

I realise the problem. It was the server that was not opening the port 10000/udp. After the server opened the port, it worked.

Besides how can i change the
*

* <meta itemprop="description" content="Join a WebRTC video conference powered by the Jitsi Videobridge" />

* <meta itemprop="image" content="images/jitsilogo.png?v=1" />

i got the same issue and i found my jitsi video bridge service stopped.

but it is stopping did not find the solution

Is it mean my solution is work?

1 Like

I have already done that but not working
error is oom killer killed the jvb