Unable to updating jitsi-meet to latest version (April 21) on a self hosted ubuntu

Hi,

Saw at stable release page that a new jitsi-meet version was released:
jitsi-meet_2.0.5765-1_all.deb 15-Apr-2021 21:07 3344

Following this update guide to update,

Running: sudo apt-get update followed by sudo apt-get upgrade and getting:

The following packages have been kept back: jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2

root@meet-server:~# sudo apt-get update
Hit:1 http://packages.prosody.im/debian focal InRelease
Get:2 https://download.jitsi.org stable/ InRelease [1,882 B]              
Hit:3 http://il.archive.ubuntu.com/ubuntu focal InRelease                                                                                                   
Hit:4 http://il.archive.ubuntu.com/ubuntu focal-updates InRelease                                                                                           
Hit:5 http://il.archive.ubuntu.com/ubuntu focal-backports InRelease                                                                                         
Hit:6 http://il.archive.ubuntu.com/ubuntu focal-security InRelease                                                                                          
Fetched 1,882 B in 12s (157 B/s)                                                                                                                            
Reading package lists... Done
root@meet-server:~# sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.
root@meet-server:~# sudo apt-get upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  jicofo jitsi-meet jitsi-meet-prosody jitsi-meet-web jitsi-meet-web-config jitsi-videobridge2
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.

Ubuntu 20.04.2 LTS

dpkg -l | grep jitsi

ii  jitsi-meet                           2.0.5390-3                            all          WebRTC JavaScript video conferences
ii  jitsi-meet-prosody                   1.0.4628-1                            all          Prosody configuration for Jitsi Meet
rc  jitsi-meet-turnserver                1.0.4900-1                            all          Configures coturn to be used with Jitsi Meet
ii  jitsi-meet-web                       1.0.4628-1                            all          WebRTC JavaScript video conferences
ii  jitsi-meet-web-config                1.0.4628-1                            all          Configuration for web serving of Jitsi Meet
ii  jitsi-videobridge2                   2.1-416-g2f43d1b4-1                   all          WebRTC compatible Selective Forwarding Unit (SFU)

I might be able to force it, as stated in this askubuntu answer by trying sudo apt-get --with-new-pkgs upgrade but I thought I’ll check here first.

Basically trying to update jitsi-meet from jitsi-meet 2.0.5390-3 (21 Jan21) to jitsi-meet_2.0.5765-1 (15 Apr21)
Any ideas? Thanks

output?

sudo apt-mark showhold

sudo apt-mark showhold has no output

sudo apt-get dist-upgrade -d
1 Like

I would go ahead and run this:

My coworker sshed and ran sudo apt update && sudo apt upgrade and it seem to just work… not sure…

Anyway thanks

1 Like

I have tried all the above procedures and suggestions but it will not allow me to update and continues to hold back? Any suggestions?

Check this out, perhaps it’ll help:

I have tried your suggestions I purged and tried to reinstall this is the message I now receive:
The following packages have unmet dependencies:
jitsi-meet : Depends: jitsi-meet-prosody (= 1.0.5675-1) but it is not going to be installed
Recommends: jitsi-meet-turnserver (= 1.0.5675-1) but it is not going to be installed or
apache2 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

You need prosody 0.11