Unable to Start Live Recording on Jitsi meet

Hi All,
I am new to this platform. I have done all Jitsi-meet setup and other configurations and its running well.
later i came with live recording or live streaming configurations. I’ve done all changes as per Requirement for Jibri.
While Starting Live Recording It says Recording Started and then Shows Recording failed to start
and i also tried other meeting session then it says All Records are currently busy

Backend Logs:
Jicofo 2020-05-02 17:28:05.473 INFO: [32] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.009S. Sticky failure: false
Jicofo 2020-05-02 17:28:09.352 INFO: [70] org.jitsi.jicofo.recording.jibri.JibriSession.log() Starting session with Jibri jibribrewery@internal.auth.meet.#########.com/jibri
Jicofo 2020-05-02 17:28:09.352 INFO: [70] org.jitsi.jicofo.recording.jibri.JibriSession.log() Starting Jibri jibribrewery@internal.auth.meet.#########.com/jibri for stream ID: null in room: test5@conference.meet.#########.com
Jicofo 2020-05-02 17:28:09.367 INFO: [70] org.jitsi.jicofo.recording.jibri.JibriSession.log() Updating status from JIBRI: for test5@conference.meet.#########.com
Jicofo 2020-05-02 17:28:09.368 INFO: [70] org.jitsi.jicofo.recording.jibri.JibriSession.log() Got Jibri status update: Jibri jibribrewery@internal.auth.meet.#########.com/jibri has status pending and failure reason null, current Jibri jid is jibribrewery@internal.auth.meet.#########.com/jibri
Jicofo 2020-05-02 17:28:09.368 INFO: [70] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Started Jibri session
Jicofo 2020-05-02 17:28:10.229 INFO: [28] org.jitsi.jicofo.recording.jibri.JibriDetector.onInstanceStatusChanged().137 Received Jibri jibribrewery@internal.auth.meet.#########.com/jibri status
Jicofo 2020-05-02 17:28:10.229 INFO: [28] org.jitsi.jicofo.recording.jibri.JibriDetector.notifyJibriStatus().175 Jibri: jibribrewery@internal.auth.meet.#########.com/jibri available: false
Jicofo 2020-05-02 17:28:10.273 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriSession.log() Updating status from JIBRI: for test5@conference.meet.#########.com
Jicofo 2020-05-02 17:28:10.274 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriSession.log() Got Jibri status update: Jibri jibribrewery@internal.auth.meet.#########.com/jibri has status off and failure reason error, current Jibri jid is jibribrewery@internal.auth.meet.#########.com/jibri
Jicofo 2020-05-02 17:28:10.274 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriSession.log() Jibri is no longer pending, cancelling pending timeout task
Jicofo 2020-05-02 17:28:10.274 WARNING: [43] org.jitsi.jicofo.recording.jibri.JibriSession.log() failureReason was non-null but shouldRetry wasn’t set, will NOT retry
Jicofo 2020-05-02 17:28:10.274 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriSession.log() Jibri failed and signaled that we should not retry the same request
Jicofo 2020-05-02 17:28:10.275 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Got jibri status off and failure error
Jicofo 2020-05-02 17:28:10.276 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriRecorder.log() Publishing new jibri-recording-status: in: test5@conference.meet.#########.com
Jicofo 2020-05-02 17:28:10.277 INFO: [43] org.jitsi.jicofo.recording.jibri.JibriSession.log() Cleaning up current JibriSession
Jicofo 2020-05-02 17:28:10.280 INFO: [28] org.jitsi.jicofo.recording.jibri.JibriDetector.onInstanceStatusChanged().137 Received Jibri jibribrewery@internal.auth.meet.#########.com/jibri status
Jicofo 2020-05-02 17:28:10.281 INFO: [28] org.jitsi.jicofo.recording.jibri.JibriDetector.notifyJibriStatus().175 Jibri: jibribrewery@internal.auth.meet.#########.com/jibri available: false
Jicofo 2020-05-02 17:28:10.389 INFO: [28] org.jitsi.jicofo.recording.jibri.JibriDetector.onInstanceStatusChanged().137 Received Jibri jibribrewery@internal.auth.meet.#########.com/jibri status
Jicofo 2020-05-02 17:28:10.389 INFO: [28] org.jitsi.jicofo.recording.jibri.JibriDetector.notifyJibriStatus().175 Jibri: jibribrewery@internal.auth.meet.#########.com/jibri available: false
Jicofo 2020-05-02 17:28:15.474 INFO: [32] org.jitsi.jicofo.health.Health.log() Performed a successful health check in PT0.01S. Sticky failure: false

There may be several reasons to this problem, we can check one by one starting from Jibri.
a. If you have already installed Jibri instance in another machine, make sure you can connect to Jitsi instance port 5222. Normally Jibri log is saying that it couldn’t able to connect to port 5222. Int that case, you need to enable this port at Jitsi instance by running .
ufw allow 5222
b. If your Jibri server says, authentication issue, check the following users are configured at Prosody, and xmpp domain is correctly pointed.

“xmpp_server_hosts”: [
“your jitsi public domain example : meet.jitsi.org
],

    "xmpp_domain": "your jitsi public domain",
        
        "control_login": {
          
            "domain": "auth.<your jitsi public domain>",
          
            "username": "jibri",
            "password": "<password configured at prosody>"
        },
        
        "control_muc": {
            "domain": "internal.auth.<your jitsi public domain>",
            "room_name": "JibriBrewery",
            "nickname": "jibri"
        },
       
        "call_login": {
            "domain": "recorder.<your jitsi public domain>",
            "username": "recorder",
            "password": "<password configured at prosody>"
        },

c. If everything is okay from Jibri side, then you need to check the jicofo SIP configurations. Check the following configurations are okay
org.jitsi.jicofo.BRIDGE_MUC=JvbBrewery@internal.auth.[your public jitsi domain]
org.jitsi.jicofo.auth.URL=XMPP: [your public jitsi domain]
org.jitsi.jicofo.jibri.BREWERY=JibriBrewery@internal.auth.[your public jitsi domain]
org.jitsi.jicofo.jibri.PENDING_TIMEOUT=90

1 Like

@sri Thanks for Response but no luck found above all point i have done
some doubt here
In Config.json, is below syntax is right ? :

“xmpp_server_hosts”: [
    "meet.xxxxxxxxxx.com: meet.jitsi.org”
    ],

Hi @Shrikant_Dixit
Missed your reply, The following configuration is working fine.

{

"recording_directory":"/home/ubuntu/recordings",

"finalize_recording_script_path": "",
"xmpp_environments": [
    {
        "name": "prod environment",   
       "xmpp_server_hosts": [
            "join.abc.com"
        ],
       
        "xmpp_domain": "join.abc.com",
      
        "control_login": {
          
            "domain": "auth.join.abc.com",
          
            "username": "jibri",
            "password": "<The same password you created at Prosody"
        },
    
        "control_muc": {
            "domain": "internal.auth.join.abc.com",
            "room_name": "JibriBrewery",
            "nickname": "jibri"
        },
     
        "call_login": {
            "domain": "recorder.join.abc.com",
            "username": "recorder",
            "password": "<The same password you created at Prosody"
        },
      
        "room_jid_domain_string_to_strip_from_start": "conference.",
      
        "usage_timeout": 20
    }
]

}

Please make sure the recording_directory is writable by jibri

This post was flagged by the community and is temporarily hidden.