Unable to Setup Transcriber

Hi,

I need some help on figuring out why my Jigasi is unable to join the Prosody xmpp.

I am getting this error

2020-03-28 02:06:59.789 WARNING: [39] org.jitsi.jigasi.xmpp.CallControl.().139 Always trust in remote TLS certificates mode is enabled
2020-03-28 02:06:59.790 INFO: [39] org.jitsi.jigasi.xmpp.CallControl.().158 JID allowed to make outgoing calls: jigasibrewery@internal.auth.my-domain
2020-03-28 02:06:59.926 INFO: [41] org.igniterealtime.jbosh.BOSHClient.init() Starting with 1 request processors
02:07:00 RECV (0): <stream:features xmlns=‘jabber:client’></stream:features>
2020-03-28 02:07:00.116 WARNING: [41] org.jivesoftware.smack.SASLAuthentication.selectMechanism() Server did not report any SASL mechanisms
2020-03-28 02:07:00.117 SEVERE: [41] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service
org.jivesoftware.smack.SmackException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: []. Registered SASL mechanisms with Smack: [SASL Mech: GSSAPI, Prio: 100, SASL Mech: SCRAM-SHA-1-PLUS, Prio: 100, SASL Mech: SCRAM-SHA-1, Prio: 110, SASL Mech: DIGEST-MD5, Prio: 200, SASL Mech: CRAM-MD5, Prio: 300, SASL Mech: PLAIN, Prio: 400, SASL Mech: X-OAUTH2, Prio: 410, SASL Mech: EXTERNAL, Prio: 500, SASL Mech: ANONYMOUS, Prio: 500]. Enabled SASL mechanisms for this connection: null. Blacklisted SASL mechanisms: [SCRAM-SHA-1-PLUS].
at org.jivesoftware.smack.SASLAuthentication.selectMechanism(SASLAuthentication.java:361)
at org.jivesoftware.smack.SASLAuthentication.authenticate(SASLAuthentication.java:192)
at org.jivesoftware.smack.bosh.XMPPBOSHConnection.loginInternal(XMPPBOSHConnection.java:222)
at org.jivesoftware.smack.AbstractXMPPConnection.login(AbstractXMPPConnection.java:491)
at net.java.sip.communicator.impl.protocol.jabber.LoginByPasswordStrategy.login(LoginByPasswordStrategy.java:99)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:1371)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin(ProtocolProviderServiceJabberImpl.java:970)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.initializeConnectAndLogin(ProtocolProviderServiceJabberImpl.java:795)
at net.java.sip.communicator.impl.protocol.jabber.ProtocolProviderServiceJabberImpl.register(ProtocolProviderServiceJabberImpl.java:500)
at org.jitsi.jigasi.util.RegisterThread.run(RegisterThread.java:59)
2020-03-28 02:07:00.125 WARNING: [41] service.resources.AbstractResourcesService.getI18NString().530 Missing resource for key: service.gui.ERROR
2020-03-28 02:07:00.125 WARNING: [41] service.resources.AbstractResourcesService.getI18NString().530 Missing resource for key: plugin.reconnectplugin.CONNECTION_FAILED_MSG
2020-03-28 02:07:00.140 WARNING: [51] org.jivesoftware.smack.roster.Roster.processStanza() Roster not loaded while processing Presence Stanza [id=8eO8A-11,type=error,]

############# JICOFO LOGS #############

Jicofo 2020-03-28 02:22:06.272 SEVERE: [88] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null
Jicofo 2020-03-28 02:22:06.272 INFO: [88] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2020-03-28 02:22:06.273 WARNING: [88] org.jitsi.jicofo.jigasi.TranscriberManager.log() Unable to invite transcriber due to no Jigasi instances being availableThis text will be hidden

Im not sure what I am doing wrong. Here are my properties files:

############# JIGASI PROP #############

org.jitsi.jigasi.DEFAULT_JVB_ROOM_NAME=siptest

net.java.sip.communicator.impl.protocol.SingleCallInProgressPolicy.enabled=false
net.java.sip.communicator.impl.neomedia.codec.audio.opus.encoder.COMPLEXITY=10
org.jitsi.service.neomedia.AudioMediaStream.DISABLE_DTMF_HANDLING=true
net.java.sip.communicator.packetlogging.PACKET_LOGGING_ENABLED=true
net.java.sip.communicator.impl.protocol.sip.SKIP_REINVITE_ON_FOCUS_CHANGE_PROP=true

net.java.sip.communicator.impl.protocol.jabber.accxmpp=accxmpp
net.java.sip.communicator.impl.protocol.jabber.accxmpp.ACCOUNT_UID=Jabber:jigasi@recorder.my-domain@127.0.0.1
net.java.sip.communicator.impl.protocol.jabber.accxmpp.USER_ID=jigasi@recorder.my-domain
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_SERVER_OVERRIDDEN=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.SERVER_ADDRESS=127.0.0.1
net.java.sip.communicator.impl.protocol.jabber.accxmpp.SERVER_PORT=5222
net.java.sip.communicator.impl.protocol.jabber.accxmpp.BOSH_URL=https://my-domain/http-bind
net.java.sip.communicator.impl.protocol.jabber.accxmpp.ALLOW_NON_SECURE=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.PASSWORD=a3MDJ2YnF2MG90bTUxeTI4bWMyemU=

net.java.sip.communicator.impl.protocol.jabber.accxmpp.RESOURCE=jigasi
net.java.sip.communicator.impl.protocol.jabber.accxmpp.AUTO_GENERATE_RESOURCE=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.RESOURCE_PRIORITY=30
net.java.sip.communicator.impl.protocol.jabber.accxmpp.KEEP_ALIVE_METHOD=XEP-0199
net.java.sip.communicator.impl.protocol.jabber.accxmpp.KEEP_ALIVE_INTERVAL=30
net.java.sip.communicator.impl.protocol.jabber.accxmpp.CALLING_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.JINGLE_NODES_ENABLED=false
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_CARBON_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.DEFAULT_ENCRYPTION=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_USE_ICE=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_ACCOUNT_DISABLED=false
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_PREFERRED_PROTOCOL=false
net.java.sip.communicator.impl.protocol.jabber.accxmpp.AUTO_DISCOVER_JINGLE_NODES=false
net.java.sip.communicator.impl.protocol.jabber.accxmpp.PROTOCOL=Jabber
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_USE_UPNP=false
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IM_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.SERVER_STORED_INFO_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.IS_FILE_TRANSFER_DISABLED=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.USE_DEFAULT_STUN_SERVER=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.ENCRYPTION_PROTOCOL.DTLS-SRTP=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.ENCRYPTION_PROTOCOL_STATUS.DTLS-SRTP=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.OVERRIDE_ENCODINGS=true
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.G722/8000=705
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.GSM/8000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.H263-1998/90000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.H264/90000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.PCMA/8000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.PCMU/8000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.SILK/12000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.SILK/16000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.SILK/24000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.SILK/8000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.VP8/90000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.iLBC/8000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.opus/48000=750
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.speex/16000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.speex/32000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.Encodings.speex/8000=0
net.java.sip.communicator.impl.protocol.jabber.accxmpp.BREWERY=JigasiBrewery@internal.auth.my-domain
net.java.sip.communicator.impl.protocol.jabber.accxmpp.DOMAIN_BASE=my-domain
org.jitsi.jigasi.ALLOWED_JID=JigasiBrewery@internal.auth.my-domain
org.jitsi.jigasi.BREWERY_ENABLED=true
net.java.sip.communicator.impl.neomedia.audioSystem.audiosilence.captureDevice_list=[“AudioSilenceCaptureDevice:noTransferData”]
org.jitsi.jigasi.xmpp.acc.IS_SERVER_OVERRIDDEN=true
org.jitsi.jigasi.xmpp.acc.SERVER_ADDRESS=my-domain
org.jitsi.jigasi.xmpp.acc.BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName}
org.jitsi.jigasi.xmpp.acc.BOSH_URL=https://my-domain/http-bind
org.jitsi.jigasi.xmpp.acc.VIDEO_CALLING_DISABLED=true
org.jitsi.jigasi.xmpp.acc.JINGLE_NODES_ENABLED=false
org.jitsi.jigasi.xmpp.acc.AUTO_DISCOVER_STUN=false
org.jitsi.jigasi.xmpp.acc.Encodings.H264/90000=0
org.jitsi.jigasi.xmpp.acc.Encodings.VP8/90000=0
org.jitsi.jigasi.xmpp.acc.Encodings.telephone-event/8000=0
org.jitsi.jigasi.xmpp.acc.Encodings.opus/48000=1000

org.jitsi.jigasi.xmpp.acc.OVERRIDE_ENCODINGS=true
org.jitsi.jigasi.xmpp.acc.IM_DISABLED=true
org.jitsi.jigasi.xmpp.acc.SERVER_STORED_INFO_DISABLED=true
org.jitsi.jigasi.xmpp.acc.IS_FILE_TRANSFER_DISABLED=true
org.jitsi.jigasi.xmpp.acc.KEEP_ALIVE_METHOD=XEP-0199
org.jitsi.jigasi.xmpp.acc.KEEP_ALIVE_INTERVAL=30
org.jitsi.jigasi.xmpp.acc.USER_ID=transcriber@recorder.my-domain
org.jitsi.jigasi.xmpp.acc.PASS=98NF2BVj
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false
org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true
org.jitsi.jigasi.JVB_INVITE_TIMEOUT=1800000
net.java.sip.communicator.service.gui.ALWAYS_TRUST_MODE_ENABLED=true

org.jitsi.jigasi.ENABLE_REST_SHUTDOWN=true
org.jitsi.jigasi.ENABLE_TRANSCRIPTION=true
org.jitsi.jigasi.ENABLE_SIP=false
org.jitsi.jigasi.transcription.DIRECTORY=/var/lib/jigasi/transcripts
org.jitsi.jigasi.transcription.BASE_URL=http://my-domain/
org.jitsi.jigasi.transcription.jetty.port=-1
org.jitsi.jigasi.transcription.ADVERTISE_URL=false
org.jitsi.jigasi.transcription.SAVE_JSON=false
org.jitsi.jigasi.transcription.SAVE_TXT=true
org.jitsi.jigasi.transcription.SEND_JSON=true
org.jitsi.jigasi.transcription.SEND_TXT=false
org.jitsi.jigasi.HEALTH_CHECK_DEBUG_ENABLED=false
org.jitsi.jigasi.LOCAL_REGION=ASIA/SINGAPORE

############# JIGASI CONFIG #############

JIGASI_SIPUSER=6598004517@voip.my-domain
JIGASI_SIPPWD=NDk4ZDEwMDZTEwNGUwZTdhYjMwMjg=
JIGASI_SECRET=98NF2kVj
JIGASI_OPTS=""
JIGASI_HOSTNAME=my-domain
JIGASI_HOST=localhost
GOOGLE_APPLICATION_CREDENTIALS=/root/.config/gcloud/application_default_credentials.json

JAVA_SYS_PROPS="-Djava.util.logging.config.file=/etc/jitsi/jigasi/logging.properties -DISorg.apache.commons.logging.simplelog.log.org.apache.http.wire=ERROR -Dsmack.debugEnabled=true -Dsmack.debuggerClass=org.jivesoftware.smack.debugger.ConsoleDebugger"

############# JICOFO PROP #############

org.jitsi.jicofo.jigasi.BREWERY=JigasiBrewery@internal.auth.my-domain

############# PROSODY CONFIG #############

Component “internal.auth.my-domain” “muc”
modules_enabled = {
“ping”;
}
storage = “none”
muc_room_cache_size = 1000
VirtualHost “recorder.my-domain”
modules_enabled = {
“ping”;
}
authentication = “internal_plain”

I hope someone can have a quick look through. Thank you.

– Anthony

Any way I can solve this? Ive tried running Jigasi from source code and still getting the same issue. I have already done prosodyctl adduser jigasi@recorder.my-domain.

Ive also tried jigasi@auth.my-domain and jigasi@internal.auth.my-domain.

I do get these logs from prosody:
Apr 01 03:03:07 jcp55d0f93b5c60 info|Incoming Jabber component connection|
Apr 01 03:03:07 callcontrol.my-domain:component info|External component successfully authenticated

And from jicofo:
Jicofo 2020-04-01 03:03:10.162 INFO: [40] org.jitsi.jicofo.ComponentsDiscovery.log() New component discovered: callcontrol.my-domain, null
Jicofo 2020-04-01 03:03:10.163 INFO: [40] org.jitsi.jicofo.JitsiMeetServices.log() Discovered SIP gateway: callcontrol.my-domain

But I’m still getting all of the errors above

2020-03-28 02:07:00.117 SEVERE: [41] impl.protocol.jabber.ProtocolProviderServiceJabberImpl.connectAndLogin().1003 Failed to connect to XMPP service
org.jivesoftware.smack.SmackException: No supported and enabled SASL Mechanism provided by server. Server announced mechanisms: []. Registered SASL mechanisms with Smack: [SASL Mech: GSSAPI, Prio: 100, SASL Mech: SCRAM-SHA-1-PLUS, Prio: 100, SASL Mech: SCRAM-SHA-1, Prio: 110, SASL Mech: DIGEST-MD5, Prio: 200, SASL Mech: CRAM-MD5, Prio: 300, SASL Mech: PLAIN, Prio: 400, SASL Mech: X-OAUTH2, Prio: 410, SASL Mech: EXTERNAL, Prio: 500, SASL Mech: ANONYMOUS, Prio: 500]. Enabled SASL mechanisms for this connection: null. Blacklisted SASL mechanisms: [SCRAM-SHA-1-PLUS].

and when pressing closed captions

Jicofo 2020-03-28 02:22:06.272 SEVERE: [88] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null
Jicofo 2020-03-28 02:22:06.272 INFO: [88] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2020-03-28 02:22:06.273 WARNING: [88] org.jitsi.jicofo.jigasi.TranscriberManager.log() Unable to invite transcriber due to no Jigasi instances being availableThis text will be hidden

Any guidance would be greatly appreciated. Thank you.

Wrong password.
Make sure you base64 the password in the props file, you can use https://www.base64encode.org/ to do the base64 encoding.

Hi,

Thank you for the help. I realised the issue was not the password.

I followed this config file and worked flawlessly. Probably need to update the Jigasi Github main page to use this sample.

https://raw.githubusercontent.com/jitsi/docker-jitsi-meet/master/jigasi/rootfs/defaults/sip-communicator.properties

Thanks again!

@Anthony_Garcia

What was the difference you found in the configuration ? Can you tell me the specific value helped you to fix this issue?

Thanks and Regards
Swathi

Hi,

I didnt check the difference but I just used this and filled up the information needed.

https://raw.githubusercontent.com/jitsi/docker-jitsi-meet/master/jigasi/rootfs/defaults/sip-communicator.properties

Hi

I have compared everything, I have exactly same configuration with me.

Swathi