Unable to set max users for a room

Hi

I tried to set max users as per the threads [jitsi-users] Max users per room & How to disable or customize some features?

I modified /etc/prosody/conf.d/mydomain.cfg.lua and added the following

Component "mydomain.com" "muc"
storage = "null"
muc_max_occupants = 2
modules_enabled = {
"muc_meeting_id";
"muc_domain_mapper";
-- "token_verification";
"muc_max_occupants";
}

And also copied https://github.com/jitsi/jitsi-meet/tree/master/resources/prosody-plugins to /usr/lib/prosody/modules

After this I restarted videobridge, jicofo and prosody. But still I could find its allowing more members to join the same room,

Can you please help me to fix the max users

Have you checked prosody logs for errors?

Hi,

I have the same problem. There are no errors in the prosody log.

When I make a log output in the beginning of the mod_muc_max_occupants.lua file, it will be shown, but when a add a log output in the check_for_max_occupants function, it doesn’t work. It seems that the event “muc-occupant-pre-join” is not fired an so the function isn’t called.

Any ideas?

Thanks.

It is available only in prosody-trunk or 0.11.

My prosody version was 0.10. Now I have installed prosody-trunk 747, but it doesn’t work:

  1. I have set muc_max_occupants = 2, but only one participant can join the meeting.

  2. I get following error: Traceback[c2s]: /usr/lib/prosody/util/cache.lua:66: table index is nil
    I have set storage to null, but the error is still there.

Thanks for your helps.

I have installed prosody 0.11.5, too. Same errors here.

This is wrong storage setting in prosody.

What is the right setting? I have set storage to null, none, internal and memory. But in all cases I get the same error. Can you help me?