Unable to see other users in Jitsi Meeting

Hey everyone. I’m having some issues connecting to a Jitsi Meeting with other users. I’ve only tested with one other user at this point, so can’t even get a 1:1 conference call working. Whenever, we both try to connect, it takes us to the meeting but we can’t see or hear each other. In fact, I can’t even unmute my mic or text chat in meeting room. I’ve perused this forum and it sounds like I might be running into a network/NAT issue. I followed the self hosting guide. I’m using an Azure VM and have opened up all of the inbound ports referred to in the guide using ufw and from within the Azure NSG, as well as enabled IP forwarding from the Azure NIC settings. Also performed the Advanced Configuration settings in the set up guide. I’m stuck at this point so would appreciate any pointers, thanks.

Post your js console logs here, do you see any errors?

Do you access the server using the same address you used during installation?

Wow, ya I do. Not sure why I’m getting ERR_CERT_AUTHORITY_INVALID. I’m using the self-signed cert generated during set up. Is that just an error because it’s self-signed?

Yes, I do access the server using the same public address used during set up. I have a domain name set up mapped to the public address.

Ok, update. I noticed in the console logs that it would refer to the IP address of the server sometimes and other times refer to the domain, so I tried to test by navigating straight to the IP address vice domain and it’s working. I have no idea why that is, but I’m assuming it’s a config issue somewhere.
This is my /videobridge/sip-communicator.properties file:


I x’d out the IP addresses. If I replace the IP address with the domain name will that fix the issue or should I nuke this instance, reinstall, and put the domain name in instead of the IP during setup?