Unable to locate package jitsi-meet

Hi Everyone,

I’m trying to install jitsi meet on debian and I followed steps from this page https://jitsi.org/downloads/

However, the installation is unable to locate the jitsi meet package.

Attached is the snapshot of steps I took.

thank you in advance!

snapshot|690x489

Your screenshot failed to upload.

My advise it to follow this: https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

Hi Dimencho,

I am not sure what happen to the attachment. here is the link: http://storage.vplaya.com/snapshot.png

I will however also try the link you shared.

Thank you.

apt-update seem to be taking to long as shown from the this snapshot http://storage.vplaya.com/2.png

Can I quite, start the installation and skip the update command?

There is an error on your first screenshot, about apt-transport-https. In the quick install guide this is mentioned, how to proceed.
You cannot install without apt update finishes. But you need to install apt-transport-https before updating.

You are correct, this “apt-get install apt-transport-https” worked and I managed to pass that stall. Now I’m continuing wit the installation :slight_smile:

Thank you so much.

Hi Damencho,

I need to thank you so much as I managed to install the application successfully. I only bumped into the ssl glitch because my domain was running under cloudflare. so I then decided to point my domain directly to my server IP and install let’s encrypt ssl and all worked well.

Thanks once again.

I’m getting the same problem, but I followed the docs word for word. Besides setting the FDQN and get same error. Is there any reason that would be causing my issue? Should I destroy my droplet and start over, I scanned and didnt see any errors but maybe i missed one? Or is there a way to start over without destroying my droplet? I’m semi knew to this side of programming, mostly do front end stuff.

The docs are correct but you probably made the same mistake I made, @mlynchdev, you used your user to install jitsi and forgot ro run the add repository step as root since the docs assume the root user for install. While the other commands like apt install throw a visible error when not performed as root the step where you add the repo doesn’t do so. So, best is to step into root via sudo su and then run the steps or add a sudo to every command. Good luck

1 Like

Thanks, got it handled, yeah, I’m not used to not being root user :smiley:

I am installing Jitsi again because my VPS died in the fire of OVH building in Strasbourg.

I followed exactly the steps at Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook but of course I used sudo for apt.

Still, I have

debian@meet:~$ sudo apt install jitsi-meet
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package jitsi-meet
debian@meet:~$ ls -la /etc/apt/sources.list.d
total 12
drwxr-xr-x 2 root root 4096 Mar 10 17:28 .
drwxr-xr-x 7 root root 4096 Nov 25 16:14 ..
-rw-r--r-- 1 root root   89 Mar 10 17:28 jitsi-stable.list
debian@meet:~$ cat /etc/apt/sources.list.d/jitsi-stable.list 
deb [signed-by=/usr/share/keyrings/jitsi-keyring.gpg] https://download.jitsi.org stable/

/usr/share/keyrings/jitsi-keyring.gpg is there, I suppose that if would be wrong that would result in an error but there is no error.

So why is this package not found?

By the way, “apt show apt-transport-https” says: “This is a dummy transitional package - https support has been moved into the apt package in 1.5. It can be safely removed.” so maybe that could be removed from the installation guide.

the output?

sudo apt-get update

I tried on two VPSs from different providers:

debian@meet:~$ sudo apt-get update
Hit:1 http://mirrors.gandi.net/debian buster InRelease
Get:2 http://mirrors.gandi.net/debian buster-updates InRelease [51.9 kB]      
Hit:3 http://security.debian.org/debian-security buster/updates InRelease     
Get:4 https://download.jitsi.org stable/ InRelease [1882 B]                   
Get:5 https://download.jitsi.org stable/ Packages [49.9 kB]
Fetched 104 kB in 1s (75.5 kB/s)    
Reading package lists... Done
debian@meet:~$ 

on another one:

debian@meet2:~$ sudo apt update
sudo: unable to resolve host meet2: Name or service not known
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease                                                         
Hit:3 http://deb.debian.org/debian buster-updates InRelease                                                 
Hit:4 https://download.jitsi.org stable/ InRelease                                                          
Reading package lists... Done                       
Building dependency tree       
Reading state information... Done
All packages are up to date.
debian@meet2:~$

The first one should work now
The second one seems to have a resolvation problem

Thanks ! It works now on the first one (Gandi) !
For the second one (OVH), I’ll further check the hostname resolution problem.