Unable to let jitsi-meet work after installation

Hello, I’m trying to install jitsi-meet different times on Ubuntu 18.04

Everytime I try to install it, something doesn’t work, first time I found that it was colliding with webmin, so I changed port to webmin, nothing good…

I paste here some code logs
/var/log/jitsi/jvb.log

SEVERE: [18] Health.doRun#300: Health check failed in 0ms:
java.lang.Exception: Failed to bind single-port
at org.jitsi.videobridge.health.Health.doCheck(Health.java:143)
at org.jitsi.videobridge.health.Health.doRun(Health.java:266)
at org.jitsi.utils.concurrent.PeriodicRunnableWithObject.run(PeriodicRunnableWithObject.java:87)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.run(RecurringRunnableExecutor.java:216)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.runInThread(RecurringRunnableExecutor.java:292)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor.access$000(RecurringRunnableExecutor.java:36)
at org.jitsi.utils.concurrent.RecurringRunnableExecutor$1.run(RecurringRunnableExecutor.java:328)

/var/log/prosody/prosody.err

portmanager error Error binding encrypted port for https: No key present in SSL/TLS configuration for https port 5281

I’m a lot frustrated, I also had to purge jitsi-meet-turnserver because was colliding with nginx

Here is my full bash log, I’ve just cleaned some stuff and I’ve no firewall enabled since it was amazing that nothing worked

ufw allow in ssh
ufw allow in 80/tcp
ufw allow in 443/tcp
ufw allow in 10000/20000:udp
ufw allow in 10000:20000/udp
ufw enable
echo ‘deb cut for prevent antispam stable/’ >> /etc/apt/sources.list.d/jitsi-stable.list
wget -qO - cut for prevent antispam | sudo apt-key add -
apt update;apt upgrade -y
nano /etc/hosts
nano /etc/hostname
reboot
apt install software-properties-common apt-transport-https
dpkg-reconfigure tzdata
add-apt-repository ppa:nginx/stable
apt update;apt install nginx
apt install perl libnet-ssleay-perl openssl libauthen-pam-perl libpam-runtime libio-pty-perl apt-show-versions python
apt install jitsi-meet
/usr/share/jitsi-meet/scripts/install-letsencrypt-cert.sh
add-apt-repository ppa:ondrej/nginx-mainline
apt purge nginx
apt-get purge jigasi jitsi-meet jitsi-meet-web-config jitsi-meet-prosody jitsi-meet-turnserver jitsi-meet-web jicofo jitsi-videobridge2
apt install nginx-full
apt install jitsi-meet
add-apt-repository ppa:openjdk-r/ppa
apt update;apt install openjdk-8-jdk openjdk-8-jre
apt upgrade -y
apt install jitsi-meet
service nginx status
netstat -tulpn | grep 443
netstat -tulpn | grep :443
ufw allow 443
netstat -ano | grep 443
add-apt-repository ppa:ondrej/php
apt update;apt upgrade -y; apt install php7.4-fpm
sudo netstat -tulpn
service nginx start
service java stop
service jitsi-videobridge2 stop
service nginx start
sudo fuser -k 443/tcp
service nginx start
apt-get purge jitsi-meet-turnserver
service nginx start

Now I have no video or audio while doing also p2p conferences and anything also in 3 in the same room…

But on another server worked flawlessy also with no need to remove anything or do anything more.

What I am doing wrong? what more should I check?

Something else is listening on port 10000, webmin maybe?

1 Like

webmin reconfigured to work on port 666

netstat -tulpn | grep :10000
udp 0 0 0.0.0.0:10000 0.0.0.0:* 684/perl
netstat -ano | grep 10000
udp 0 0 0.0.0.0:10000 0.0.0.0:* off (0.00/0/0)
ls -l /proc/684/exe
lrwxrwxrwx 1 root root 0 Apr 3 00:39 /proc/684/exe -> /usr/bin/perl

than I found out that doing the next command will not change udp to webmin:
/etc/webmin/miniserv.conf

port=10000

so to all webmin users:

WARNING webmin collide with port 10000 UDP
so to be able to use it:

  • change the file listed up with another port
    launch the command:

service webmin restart

  • then login back to webmin
  • Go in Webmin --> Webmin Configuration --> Ports and Addresses

Listen for broadcasts on UDP port
Set it to the new port you choose

  • apply
  • restart Webmin again
  • restart your server

Jitsi will now work!

Thanks a lot @damencho I didn’t think about the UDP port!!!

P.S. now I will open a new thread about another question :laughing:

1 Like

Little edit, I suggest to use port 250 instead of 666

Why?
Because port 250 is reserved but not yet used by any protocol, while 666 is dedicated to Doom game and some malware used that port (making it potentially being blocked by some firewalls)