Unable to invite transcriber due to no Jigasi instances being available

As long as there are no errors it works fine now. Observing one issue though:

  1. Only showing subtitles at host, not showing at the other participant. No CC button at participant.

You need to upgrade to the latest version of meet.

Did participant enable the cc?

@damencho ere’s no ‘CC’ button at participant.
@Freddie I just uninstalled and installed everything again, from stable. All the versions are same.

Mon Feb 1 15:26:18 UTC 2021: Currently Installed Versions:


ii jitsi-meet 2.0.5390-3 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4628-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4628-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4628-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-416-g2f43d1b4-1 all WebRTC compatible Selective Forwarding Unit (SFU)
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii prosody 0.11.7-1~bionic4 amd64 Lightweight Jabber/XMPP server
ii jigasi 1.1-166-g929a439-1 amd64 Jitsi Gateway for SIP


The cc should appear for regular participants after the moderator enables the captions in the meeting and the jigasi enters the meeting.

@damencho It’s not by default. But it appears at participant side, if we make that participant a moderator.

So you say, that moderator enables cc, and start seeing cc and guests are not seeing the cc button after that happens (they should see cc button once they see the ‘TR’ indication in the right up cornoer)? They do not see it initially as they are not moderators and if you promote them they will start seeing it even when transcriptions are not running.

  1. Host joins. CC button available
  2. Participant joins. No CC.
  3. Host starts transcription by clicking on CC. Still no CC at participant. Participant can see that the transcirber has joined though.
  4. Host makes the participant a moderator. Now CC button is visible at participant.

One observation. TR doesn’t appear when hiddenDomain is not configured.

But when hiddenDomain is configured, TR appears and the participant sees the CC when host starts transcribing.

It is working as you described only when hidden domain is configured. Do you think I’m missing something?

Well, yeah I’m not sure about the whole logic there need to look at it, but this is how it is designed to be used, you do not want to see the transcriber as a participant, the same happens, and for jibri. Those participants are hidden.

OK. For the reference of other users, we did two changes, after quick install:

  1. commented out net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-BOSH_URL_PATTERN=https://{host}{subdomain}/http-bind?room={roomName} (jigasi/sipcommunicator)
  2. Configured hidden domain
    org.jitsi.jigasi.xmpp.acc.USER_ID=hiddenuser@myhiddendomain.com
    org.jitsi.jigasi.xmpp.acc.PASS=hiddenpassword

I am sure CC button for participant was visible, even when hiddenDomain was not configured. But that was on 11-Jan-2021.

@damencho Thank you for your quick help, as usual.

Do you know why it was not working when Bosh url was not commented? Or should that be looked into?

For some reason jigasi was not able to access https://yourdomain on port 443 … I suspect again firewall blocking this request as this is a request getting out of your network and hitting back again, sometimes those are disabled by default.

Ok. Got it. Thanks again for your help.