Unable to invite transcriber due to no Jigasi instances being available

@damencho sorry to waste your time with this, I would rather have asked useful questions. Maybe you could use these threads to make the readme clearer or idiot proof even.

It is now onward to actual transcription/google related errors.

Glad you progressed on your own. That’s why we have a public forum as people struggling with similar issues can then find resolutions of their problems.

1 Like

Oh boy, convert correctly from plain to base64 is something you can’t have any error or you’ll be running in circles, like I did.

Thanks for emphasize it, maybe I would go another 3 days in circles if not.

@damencho i have setup jigasi dial in,dial out using voximplant.Now i am doing transcription.Following is the jicofo log:
Jicofo 2020-10-08 14:43:43.669 SEVERE: [70] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for nullJicofo 2020-10-08 14:43:43.669 INFO: [70] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2020-10-08 14:43:46.033 SEVERE: [70] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for nullJicofo 2020-10-08 14:43:46.034 INFO: [70] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2020-10-08 14:43:50.226 INFO: [28] org.jitsi.jicofo.ChatRoomRoleAndPresence.log() Chat room event ChatRoomMemberPresenceChangeEvent[type=MemberLeft sourceRoom=org.jitsi.impl.protocol.xmpp.ChatRoomImpl@521161ae member=ChatMember[siptest@conference.artaticsxauuio.com/7115f40c, jid: wp-_tlh9_3wrkn2o@artaticsxauuio.com/CdNebsqz]@2037347613]
Jicofo 2020-10

Can you tell me whats the error

Hello,

I’m facing same issue on my new setup today on AWS EC2.

Jicofo 2020-10-27 11:29:37.177 SEVERE: [228] org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null
Jicofo 2020-10-27 11:29:37.177 INFO: [228] org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber
Jicofo 2020-10-27 11:29:37.178 WARNING: [228] org.jitsi.jicofo.jigasi.TranscriberManager.log() Unable to invite transcriber due to no Jigasi instances being available

can anyone help in this?

  1. Installed jitsi & jigasi using Self-Hosting Guide - Debian/Ubuntu server · Jitsi Meet Handbook
  2. Set all required properties in jigasi/sip-communicator.properties, for transcription(Google). Gcloud installed and credentials are in right place.
    Reference: Jitsi video conference deployment (4): real-time voice-to-subtitle conversion in video conferences - Programmer Sought

Errors in jicofo log:
org.jitsi.jicofo.jigasi.TranscriberManager.log() Error finding room for null
org.jitsi.jicofo.jigasi.TranscriberManager.log() Attempting to invite transcriber

This worked for me in my previous setup. But getting these errors, despite following the same steps(Not sure what I’m missing this time).

Can someone please help? I have tried almost all things suggested, nothing works.

@Himanshu_Koshti Were you able to resolve those errors you were facing?

@damencho Would you please help? Or point me to some documentation which might help with this?

jigasi, prosody, jitsi…all are on same system.

In case if someone needs the versions:

jitsi-meet 2.0.5390-3
jitsi-meet-prosody 1.0.4628-1
jitsi-meet-turnserver 1.0.4628-1
jitsi-meet-web 1.0.4628-1
jitsi-meet-web-config 1.0.4628-1
jitsi-videobridge2 2.1-416-g2f43d1b4-1
jigasi 1.1-166-g929a439-1
prosody 0.10.0-1build1

Have you tried updating jigasi to latest?

Also you better update prosody to 0.11, check out the threads there are instructions how to do that as it can be a bit tricky.

@damencho I just uninstalled everything. Installed prosody 0.11.7-1~bionic4.
Installed jitsi and jigasi using quick install guide. Still see the same issue of “room is null” in jicofo logs when I click on “CC” button.

Below are the current versions. Jitsi seems to be the latest one already. Do you want me to install it from sources?

Sat Jan 30 16:50:24 UTC 2021: Currently Installed Versions:


ii jitsi-meet 2.0.5390-3 all WebRTC JavaScript video conferences
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii jitsi-meet-turnserver 1.0.4628-1 all Configures coturn to be used with Jitsi Meet
ii jitsi-meet-web 1.0.4628-1 all WebRTC JavaScript video conferences
ii jitsi-meet-web-config 1.0.4628-1 all Configuration for web serving of Jitsi Meet
ii jitsi-videobridge2 2.1-416-g2f43d1b4-1 all WebRTC compatible Selective Forwarding Unit (SFU)
ii jitsi-meet-prosody 1.0.4628-1 all Prosody configuration for Jitsi Meet
ii prosody 0.11.7-1~bionic4 amd64 Lightweight Jabber/XMPP server
ii jigasi 1.1-166-g929a439-1 amd64 Jitsi Gateway for SIP


Also please find the jigasi sip communicator properties file attached herewith…jigasi_sip_communicator.txt (14.2 KB)

Clear your Jigasi and Prosody logs, restart all services, try initiating transcription again and then post those 2 logs.

Hi @Freddie

  1. Cleared logs
  2. Restarted all services
  3. Joined meeting
  4. Clicked on CC(room is null)
  5. Invited jitsi_meet_transcribe(failed)

Please find all logs attached herewith…
jigasi.log (63.8 KB) jvb.log (7.7 KB) prosody.err.txt (1.1 KB) prosody.log (5.7 KB) jicofo.log (30.3 KB)

Jigasi can’t connect to XMPP. Check your XMPP password in Jigasi SIP, confirm it matches what you set in the jigasi account you created.

The passwords seems to be correct.

net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1=acc-xmpp-1
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.ACCOUNT_UID=Jabber:jigasi@auth.example.com
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.USER_ID=jigasi@auth.example.com
net.java.sip.communicator.impl.protocol.jabber.acc-xmpp-1.PASSWORD=emN1TmFhS2FzTWFyaGw2VQ== (This is generated automatically while installing)

For above, prosody: auth.example.com

#cat jigasi.dat
return {
[“password”] = “zcuNaaKasMarhl6U”;
};

#echo -n zcuNaaKasMarhl6U|base64
emN1TmFhS2FzTWFyaGw2VQ==

#Jigasi Authentication
org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true
org.jitsi.jigasi.xmpp.acc.USER_ID=6YV_IApa@example.com
org.jitsi.jigasi.xmpp.acc.PASS=v1Xuoo24
org.jitsi.jigasi.xmpp.acc.ANONYMOUS_AUTH=false

For above, prosody account: example.com (Account created by me)
#cat 6yv%5fiapa.dat
return {
[“password”] = “v1Xuoo24”;
};

Why don’t you try disabling secure domain for now and testing it first? So, disable secure domain and comment out the Jigasi Authentication bit of your SIP.

Done. Same error.

Please find prosody configs attached.prosody-cfg-lua.txt (9.3 KB) prosody-example-com.txt (3.5 KB)

Google transcription worked for me, with same steps(well almost), on 11-Jan-2021.
Did jigasi version change since then?

Same error in jigasi and prosody?

Jigasi was updated with the latest release.

Try including this in your IP properties:

org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true

Added org.jitsi.jigasi.xmpp.acc.ALLOW_NON_SECURE=true

Please note I am using self signed certificates.

Here are the logs.
jigasi.log (53.6 KB) prosody.err.txt (1.1 KB) prosody.log (5.0 KB) jicofo.log (25.4 KB)