Unable to install on Ubuntu 16.04 LTS

Tried to install Meet on a VPS by the tutorial for 18.04 LTS but it just fails with

The following packages have unmet dependencies:
jitsi-meet : Depends: jicofo (= 1.0-740-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Any idea why?

Is this 16.04 or 18.04 as you had stated both. I think 16.04 is missing a dependency jicofo and jvb need ruby-hocon. But anyway you should not be using something that is End of Life and is 5 years old… You better move to 20.04.

It is on 16.04 LTS and sadly moving to never version is not doable at this time.

If I remember correctly, I did install version 5390(version before the current stable) on Ubuntu-16.

So you might check if that version can be installed, instead of the latest one…

Not sure if there’s any guide for doing that…

Is it possible to install container in this release?

Dont think so it is a container based VPS not sure I can do container in container.

But I think I got it solved by doing a downgrade.

At least now I have a pretty clean install and the scripts to do install if I need them later

My script if anyone is interested

sudo apt install curl -y

sudo apt install gnupg2 -y

sudo apt install openjdk-8-jdk -y

sudo apt install apt-transport-https -y

sudo apt-add-repository universe

curl https://download.jitsi.org/jitsi-key.gpg.key | sudo sh -c ‘gpg --dearmor > /usr/share/keyrings/jitsi-keyring.gpg’

echo ‘deb [signed-by=/usr/share/keyrings/jitsi-keyring.gpg] https://download.jitsi.org stable/’ | sudo tee /etc/apt/sources.list.d/jitsi-stable.list > /dev/null

sudo apt update

sudo apt-get install jitsi-meet-prosody=1.0.4289-1 jitsi-meet=2.0.4857-1 jicofo=1.0-612-1 jitsi-meet-web=1.0.4289-1 jitsi-meet-web-config=1.0.4289-1 jitsi-videobridge2=2.1-273-g072dd44b-1 -y

1 Like

You saved my ass! Thank you!
Note: I had to convert the ‘ and ’ characters to a standard apostrophe (the forum seems to have converted the symbols) and remove the click counter number behind the link.
So this should be it:

sudo apt install curl -y
sudo apt install gnupg2 -y
sudo apt install openjdk-8-jdk -y
sudo apt install apt-transport-https -y
sudo apt-add-repository universe
curl https://download.jitsi.org/jitsi-key.gpg.key | sudo sh -c 'gpg --dearmor > /usr/share/keyrings/jitsi-keyring.gpg'
echo 'deb [signed-by=/usr/share/keyrings/jitsi-keyring.gpg] https://download.jitsi.org stable/' | sudo tee /etc/apt/sources.list.d/jitsi-stable.list > /dev/null
sudo apt update
sudo apt-get install jitsi-meet-prosody=1.0.4289-1 jitsi-meet=2.0.4857-1 jicofo=1.0-612-1 jitsi-meet-web=1.0.4289-1 jitsi-meet-web-config=1.0.4289-1 jitsi-videobridge2=2.1-273-g072dd44b-1 -y

Mind that these versions will stop working in few weeks with Chrome, you will be able to apply for an origin reverse trial till December or something like that and after that, there will be no option …