Unable to init avatar - no id and GET https://localhost/http-pre-bind?room=test net::ERR_CONNECTION_REFUSED

Hi Everyone!

I’m brand new to Jitsi and the community and wanted to say hello and reach out to see if anyone has seen this issue before.

So I’ve just taken over a project using npm with react, js, jitsi, etc.
After obtaining my files, removing the package-lock.json file, I’ve run my “npm install” command and “make dev” command and it has successfully compiled and told me it’s running on https://localhost:8080 which is great news.

I’m able to view the welcome jitsi screen, but when I proceed to my test page in the browser
localhost:8080/test?person=true
I should be seeing the webcam with video and audio but I simply get a grey screen. My button for leaving the call shows up but there’s no video

Upon checking the console of Google Chrome while it’s running I see several errors come up but these two are the first few errors that pop up.

<g.updateView>: Unable to init avatar - no id g {_isModerator: false, isAudioMuted: false, hasAvatar: true, isVideoMuted: false, videoStream: null, …}

ScriptUtil.js:67 GET https://localhost/libs/analytics-ga.min.js net::ERR_CONNECTION_REFUSED
loadScript @ ScriptUtil.js:67

I honestly don’t know where to begin in troubleshooting as I’m so new to the project, npm, and jitsi.
Has anyone ever seen this issue when running a project on a local host before?

I’ve been told that the project works on the original laptop it was running on (that person is gone now and the laptop is unavailable) and my machine is like a fresh install on Mac. where I Downloaded the code, ran the two lines, and prayed that it worked.

Anyway, thanks for listening and hope to hear from someone soon!
Sincerely,
Jayce

Are you running latest master without modifications?
Why did you delete the lock file?

Hi damencho!

I downloaded the latest jitsi meet build from github yesterday morning. I was running nodejs (LTS - recommended for most users 12.14.0). I have not modified any of the files in the project once downloaded and just tried to run npm install, then make dev. It told me to run npm audit fix one time and I tried that but it didn’t fix the issue.

I believe I deleted the lock file because it stopped me from removing the npm install I had and doing the fresh install.

I just tried downloading the latest nodejs 13.5.0 and no change as well.

Hope this helps!

I just tested it and it works just fine.

git clone https://github.com/jitsi/jitsi-meet.git
cd jitsi-meet/
npm install
make dev

Are you opening localhost as http or https?

Hi damencho!

I downloaded the base jitsi meet program just now and ran it with npm install and make dev just as you did. When I test it on localhost, it works just fine (shows my webcam in the top right corner).
It looks like the problem is in my project somewhere. The common error is this one:

GET https:// localhost /http-pre-bind? room=test net::ERR_CONNECTION_REFUSED
external_connect.js?v=1:66

GET https:// localhost /libs/analytics-ga .min.js net::ERR_CONNECTION_REFUSED
ScriptUtil.js:67

OPTIONS https:// localhost /http-bind? room=test net::ERR_CONNECTION_REFUSED
strophe.js:5666

Any ideas on what might trigger these to prevent a connection in my project when the base jitsi program connects fine?

Thanks!
Jayce

These two you can ignore and this is normal.

This is not normal and the problem is that the proxy is running on https://localhost:8080 where something is trying to connect to bosh without specifying the port, you need to find that thing and fix it.

Hi Damencho!

I took a bit of time and tried to read up on Bosh as I’m not sure what it was. Just so I don’t leave anything out… this is my console when the program runs and then errors out.
Would the file dealing with Bosh be in the base Jitsi files or potentially something that was added afterwards? Any idea?

Thanks again!
Jayce

@damencho

Facing same issue when I installed using,
Document mentioned over here. https://github.com/jitsi/jitsi-meet/blob/master/doc/quick-install.md

@jmerinchuk Any Luck?

So you have installed with localhost? In general don’t do that use a DNS name!
Check whether prosody has a localhost virtual host pre-configured, if so remove it and restart prosody.

@damencho

In /etc/prosody/conf.d/xxx.xxxx.xx.cfg.lua

I checked VirtualHost: ‘xxxx.xxxx.xx’ the name which is a publicly accessible address. Anywhere else need to check. I removed everything and reinstall so, Let me know if it’s related to caching or something.

@damencho

Prosody error and log both are empty.
In jicofo and jvb both contain the same error as following.

Is prosody running at all?

@damencho
Yes, You can check here.
https://vconf.vidoly.us/http-bind

And your deployment is vconf.vidoly.us? It doesn’t seem to work.

@higunjan No luck figuring anything out yet. The whole thing is brand new to me with Jitsi and nodejs - npm, etc. Running circles trying to take the project and work backwards until it worked.

@damencho

I stopped server Yesterday. You can check now.

CONFERENCE FAILED: conference.focusDisconnected focus.vconf.vidoly.us 1

Your jicofo is not running or not connected.

@damencho

I checked jicofo.log and found following error inside it.
Something related to remote server not found. Where can I check for configuration?

You room name is wrong, fix it. it is something@conference.&lt;!--# echo..... you have a wrong domain there not sure from which config it is coming from.

1 Like

@damencho

Thank you for the help fixed it.