Unable to get Jitsi working on either Ubuntu 16.04 or Debian 10

Hi there,

I’ve tried to get Jitsi running on a vanilla Debian 10 server as well as on a vanilla Ubuntu 16.04 server.

With Debian 10 I’ve tried both openjdk-8 from the sid repositories as well as from AdoptOpenJDK. The observed behavior in the web browser is the same: I can join a room, the browser asks for permission to use webcam and mic and the Jitsi screen shows (so far so good). No video however, none of the buttons seem to do anything. It is possible to type something into the chat window but whatever I type disappears (ie. does not show in the chat).

With Ubuntu 16.04 the behavior is different; the browser keeps connecting/disconnecting. The logs show a bunch of errors such as:
j
icofo.log:Jicofo 2020-03-26 15:05:39.398 SEVERE: [16] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().309 Failed to connect/login: The following addresses failed: ‘localhost:5222’ failed because: localhost/127.0.0.1 exception: java.net.ConnectException: Connection refused (Connection refused), localhost/0:0:0:0:0:0:0:1 exception: java.net.ConnectException: Connection refused (Connection refused)

Jicofo 2020-03-26 15:05:41.399 SEVERE: [31] org.jitsi.meet.ComponentMain.log() java.net.ConnectException: Connection refused (Connection refused), host:localhost, port:5347
jicofo.log:Jicofo 2020-03-26 15:05:44.434 SEVERE: [16] org.jitsi.impl.protocol.xmpp.XmppProtocolProvider.doConnect().309 Failed to connect/login: host-unknown You can read more about the meaning of this stream error at http://xmpp.org/rfcs/rfc6120.html#streams-error-conditions

Something is listening on port 5222 and 5347 though:
netstat -ln | grep 5222
tcp 0 0 0.0.0.0:5222 0.0.0.0:* LISTEN
tcp6 0 0 :::5222 :::* LISTEN
netstat -ln | grep 5347
tcp 0 0 127.0.0.1:5347 0.0.0.0:* LISTEN
tcp6 0 0 ::1:5347 :::* LISTEN

I’ve now spend a day or so trying to get a working system on a plain VM with both Debian 10 and the recommended Ubuntu 16.04. I’ve read the how-to’s, FAQ’s and watched the video. The installation surely is quick and easy. But getting it to work not so, at least not for me. What am I missing?

Any help is much appreciated.

regards,
Jan

What is not working? Have you followed the advanced section in https://jitsi.org/qi?

Hi Damien,

Yes I have.
I think I’ve read the documentation 10 times now :frowning:
I am following the instructions to the letter, even watched the video twice.

My post (above) contains the details of what I’m observing and error messages that are (likely?) the reason why things are not working.

Should I use Debian 10, Ubuntu 16.04 or Ubuntu 18.04? Even though Ubuntu 16.04 (as recommended in the video) pulls in openjdk-8 (ie. the right version for Jitsi), I feel it’s further from a working system than my attempt with Debian 10. At least with Debian 10 I see no/few errors in the log and the browser get’s to the grey Jitsi screen. Not so with Ubuntu 16.04… the browser keeps having to connect and looking at the logs it seems due to internal Jitsi errors.

The VM sits behind a firewall; the firewall is running nginx with the exact config (2.1 KB) config that Jitsi requires. Well, to the best of my knowledge that is. The firewall forwards ports tcp 4443 and udp 10000 to the VM. nginx is the proxy accepting https and proxies that on the internal network to the VM (as per the config).

So reiterating. I’m installing a plain vanilla bare default Debian 10 or Ubuntu 16.04 VM. I follow the instructions to the letter to install Jitsi. I edit /etc/jitsi/meet/sip-communicator.properties and add two lines:

org.ice4j.ice.harvest.NAT_HARVESTER_LOCAL_ADDRESS=local-ip
org.ice4j.ice.harvest.NAT_HARVESTER_PUBLIC_ADDRESS=public-ip

I edit /etc/hosts and /etc/hostname so both refer to the FQDN.

That should be it, right?

kind regards,
Jan

On Debian 10 can you check if the prosody service is installed and running?

Do you see any issues in the
/var/log/prosody/prosody.log
/var/log/prosody/prosody.err
?

                           end users

                   |       public ip           |
               +---+---------------------------+---+
               |      router with port forward     |
               +---+---------------------------+---+
                   |                           |
                   |       local ip            |
               +---+---------------------------+---+
                   |  debian server            |
                   |                           |
                   |                           |
                   v                           |
                  443                          |
               +-------+                       |
               |       |                       |
               | Nginx |                       |
               |       |                       |
               +--+-+--+                       |
                  | |                          |
+------------+    | |    +--------------+      |
|            |    | |    |              |      |
| jitsi-meet +<---+ +--->+ prosody/xmpp |      |
|            |files 5280 |              |      |
+------------+           +--------------+      v
                     5222,5347^    ^5347   4443,10000
                +--------+    |    |    +-------------+
                |        |    |    |    |             |
                | jicofo +----^    ^----+ videobridge |
                |        |              |             |
                +--------+              +-------------+

@xranby, thanks for your reply.

The VM is still running Ubuntu 16.04. But you were right that the prosody service was not running and, apparently, not configured to start automatically at boot. Now it is running, but the behavior in the browser is still the same. The screen saying “Jitsi needs to use your microphone and camera” and the one saying “You have been disconnected. Rejoin now” keep alternating.

The prosody log has one warning:

Mar 27 15:31:55 jitsi-videobridge.meet.removed:component warn Component not connected, bouncing error for:
Mar 27 15:31:55 focus.meet.:component warn Component not connected, bouncing error for:

but also:

Mar 27 15:31:57 focus.meet.isle.nz:component info External component successfully authenticated
Mar 27 15:31:57 jcp246c770 info Incoming Jabber component connection
Mar 27 15:31:57 jitsi-videobridge.meet.removed:component info External component successfully authenticated

I’ll now save the state of the Ubuntu 16.04 machine, re-install Debian 10, then try the unstable packages. Persistence ultimately should help, I’d say…

Same problem here on a fresh debian 10. It is simply broken.

And same result, at least here, on the unstable branch: nginx wont launch because of multiple 443 declarations and xmpp will also fail because nothing is listening on 5222.

@kfx if nginx won’t launch due to multiple 443 declarations, then you need to fix that: nothing to do with Jitsi. Regarding nothing listening on 5222, check if the Prosody service is running.

I’ve tried quite a few different combinations of Debian 10 and Ubuntu 16.04 with JDK 8 and JDK 11 but have given up for now as I cannot spend another day trying to get this to work without a little bit of support how I can analyse/debug the problem.

I was aiming to offload my need for videoconferencing from the Jitsi servers to free up capacity for others and it seems the Jitsi folks are actually actively promoting that. Without their help I won’t be able to do that.

“othing to do with Jitsi.” … It IS the Jitsi pkg who is creating those multiple declarations on a FRESH and minimal debian 10 installation.

@kfx Ah, my bad (I was attempting to run Jitsi behind a firewall so my firewall and nginx proxy took care of all that). Oh well, I guess we can only hope one of the Jitsi folks is going to give us a hand here.