Unable to get jitsi-meet frontend running on local

Hi,
I am trying to work on a few changes on the frontend and for that I cloned the “jitsi-meet” repo and followed the development documentation
I ran npm install which completed without any error and then I ran make dev
Running make dev gives an error but that is because I am running git-bash on windows.

rm -fr libs
mkdir -p libs
./node_modules/.bin/node-sass css/main.scss css/all.bundle.css && \
./node_modules/.bin/cleancss css/all.bundle.css > css/all.css ; \
rm css/all.bundle.css
Rendering Complete, saving .css file...
Wrote CSS to E:\jitsimeet\jitsi-meet\css\all.bundle.css
cp \
        node_modules/rnnoise-wasm/dist//rnnoise.wasm \
        libs
cp \
        node_modules/lib-jitsi-meet//lib-jitsi-meet.min.js \
        node_modules/lib-jitsi-meet//lib-jitsi-meet.min.map \
        node_modules/lib-jitsi-meet//connection_optimization/external_connect.js \
        node_modules/lib-jitsi-meet//modules/browser/capabilities.json \
        libs
cp \
        node_modules/libflacjs/dist/min//libflac4-1.3.2.min.js \
        node_modules/libflacjs/dist/min//libflac4-1.3.2.min.js.mem \
        libs
./node_modules/.bin/webpack-dev-server
'.' is not recognized as an internal or external command,
operable program or batch file.
make: *** [Makefile:83: dev] Error 1

This is fine, after this I just run the command ./node_modules/.bin/webpack-dev-server manually and server starts up. After a few seconds, I get something like this

i 「wds」: Project is running at https://localhost:8080/
i 「wds」: webpack output is served from /libs/
i 「wds」: Content not from webpack is served from E:\jitsimeet\jitsi-meet
------ output truncated
i 「wdm」: Compiled successfully.

Now when I go to https://localhost:8080, its just a bank grey page nothing happens. Looking at the developer tools, I see below error

> translation.js:27 Uncaught ReferenceError: $ is not defined
>     at new Translation (translation.js:27)
>     at Module../modules/translation/translation.js (translation.js:60)
>     at __webpack_require__ (bootstrap:19)
>     at Module../app.js (app.js:1)
>     at __webpack_require__ (bootstrap:19)
>     at Object.0 (app.bundle.min.js?v=4027:287590)
>     at __webpack_require__ (bootstrap:19)
>     at bootstrap:83
>     at bootstrap:83

Can someone help me out in fixing this and getting this up and running.

Thanks,
Regards,
Mudasir Mirza

We do not support build the web on windows, sorry.

Hi,

thanks for the info. I have setup my raskberry pi as dev env for jitsi-meet.
I got the UI running I can access that.
However I made changes in title.html to HTML title and few other parameters and ran make dev. It started successfully but when I access the web UI it still shows “Jitsi Meet” as the title and all other options that I changed are not reflecting.

I am new to react, still learning. Is there something that I am missing.

I have also modified the interface_config.js file but still nothing is changing on the UI.

Hi,

I have been also facing the same issue. Please guide me to change the browser title.
@mudasirmirza: Did you find the solution? If yes, Could you please post here?

Still nothing. I am still trying to figure out. I added console log for and printed the interfaceConfig at the point where it sets the document.title and even there it shows the defaults and not the interfaceConfig parameters which I did set.
So still nothing much

@mudasirmirza did you find any solution of your problem if ‘Yes’ then Kindly send me the detail and method?

why not support on windows?