Unable to find endpoint to send EndpointMessage

Hi all,

We’re getting the following error and couldn’t find why

{“log”:“2020-09-08 08:00:42.702 WARNING: [19741] [confId=45a5e71cfa108ae8 gid=267154 conf_name=1180-040-170] OctoEndpointMessageTransport.endpointMessage#141: Unable to find endpoint to send EndpointMessage to: 8dd0d16d\n”,“stream”:“stderr”,“time”:“2020-09-08T08:00:42.702700269Z”}

Any help is appreciated.


Are you using jitsi-meet and jicofo? Do you have e2eping enabled in config.js?

We would need more context to debug, but here’s what the message means: Endpoint A sent a targeted message to endpoint 8dd0d16d. Endpoint A’s bridge forwarded it to another bridge via octo, and the second bridge did not know about endpoint 8dd0d16d, so the message was dropped.

There are a few possible explanations:

  1. If there are 3 or more bridges in the conference, some of them will print this message. This is a bug I just noticed, and it’s completly harmless. The message would be logged periodically.
  2. There might be a race condition between an endpoint joining the MUC (so other endpoints know about it and start sending messages to it), and all bridges in the conference being updated with the info for the new endpoint. The message would be logged once.
  3. Something else that I can’t think of.

I am pretty sure that the only case where we use targeted messages is with e2eping, which means they are harmless. In fact, we recommend disabling e2eping in config.js because it’s onlly used to display an “end-to-end RTT” in the interface and requires a lot of messages especially for large conferences.


1 Like

Hi Boris,

Thank you for your reply. We’ve disabled e2eping hope we’ll get fewer errors like the above.

I wanted to ask you about 3 or more bridges for a single conference. We’re currently divide conferences using split-based strategy not region-based. And it automatically divides conferences over more than 3 bridges, would it improve if we were to change to split-based strategy?



Did you resolve this by disabling e2eping? I’m using docker with only 1 server and no extra jvb, my server show a lot of this error message.

Today we are having test with 300 users, some users were reconnected in the middle of conference, @Boris_Grozev is this warning related to this issue?

My server specs:

  • 48 cores CPU

  • 96 GB Memory

  • bandwidth: DL 867.18 Mbit/s and UL 590.84 Mbit/s

During the test, we check that the highest UL bitrate 150 Mbps and DL bitrate 9 Mbps.


@tor Were you able to find a solution? We are getting the same error message. The error appears randomly, which results in a situation were not everyone can hear each other.

1 Like

just spun up a quick docker compose install and I’m getting these warnings as well, I am also not able to see any other participant even though I see the RTP packages arriving on the server.

WARNING: Unable to find endpoint to send EndpointMessage to: 6f87b1a1

Also getting this:

WARNING: Received request for a nonexistent endpoint: 6f374e77(conference 825b3301e2d2c019)

1 Like