Unable to create new room with JWT

Hey everyone,

I’ve finally managed to configure Jitsi to use JWT auth, generating tokens per user/room.
However, I am unable to find a way to create new rooms after enabling JWT. When I try to enter a new room name 404 is returned (404 Not Found / You can create new conversation here). Accessing any room previously created (before enabling JWT auth) is working perfectly using the generated JWT.

Any ideas?

Thanks!

This sounds strange, rooms in the default deployment are not persistent, they are destroyed in the moment there are no participants. And to enable jwt you need to restart prosody which will destroy all existing rooms.
404 is normally shown by the webserver, so you may have error in the webserver … Have you checked any logs?

I think I may have figured it out. It appears to be the hyphens in the room name…

Thanks for the quick reply @damencho!
The issue appears to be resolved if no hyphens are present in the room name.