Unable to change language

Hi,
i’m having trouble with a Jitsi install and trying to change the language to Slovenian - i’ve put “sl” into jitsi-meet config, opened a new incognito window, cleared cache…nothing changes. If i set the default language to Russian, it works (so, put “ru” into jitsi-meet config). The json files look OK for Slovenian (no JSON errors main-sl.json, languages-sl.json). The translations do not happen… Any ideas, what am i missing?

Thank you!

I seem to have solved this. If anyone runs into it i’ve had to add the language to libs/app.bundle.min.js and libs/dial_in_info_bundle.min.js, in the section the other languages are in in the form language_code:“language”.

Hello Lim00n,

I have the same issue. How did you exactly solve it? I tried to do what you did but didm¿n’t find anything in app.bundle.min.js and dial_in_info_bundle.min.js. What exactly did you change in there? Can you elaborate a little?

THX

You probably had ran at least once with english and then you had changed the language in config.js. Clean your localstorage and you will get the new default language. This is a known limitation we have.
Or test in incognito mode.

Thanks for answering. I did test in incognito mode and clear cache of Chrome in dev mode, the previous language still persisted. After a couple of hours I entered again and the language had changed. Could it be because of some server cache?

Possible, yes.

@damencho, actually that wasn’t the case. I had changed the ‘language’ manually in the Settings in WebRTC, that’s why it was showing the interface in Spanish.

I made a fresh installation with a new server, set defaultLanguage: 'es' in /etc/jitsi/meet/[domain]-config.js, cleared cache and it didn’t work. The interface is still in English. I opened it in incognito mode and also got the same result.

What can this be?

ive encountered this

i saw there is an LANG_DETECTION: false, in /usr/share/jiitsi-meet/interface-config.js that must be false to let defaultlangage fully works (in my case)

@ledahu, Thanks a lot. After setting LANG_DETECTION: false in /usr/share/jiitsi-meet/interface-config.js, defaultLanguage: 'es' in /etc/jitsi/meet/[domain]-config.js started to work.

Happy, it work for you, after verification , it doesnt for me !!! :slight_smile: :slight_smile: :slight_smile: :slight_smile:

I installed again the Jitsi server with JVB 2 and it doesn’t work. Did it work for you @ledahu?

@damencho what are the settings that we have to set in order to have the UI in a particular language for all users?


Make sure you test in incognito, you may have already set in localstorage the default en one.

@damencho how can I clear localstorage in my regular non-incognito Chrome tab to see the changes?

Deveoper -> Developer tools -> Application -> Local Storage -> select meet.jit.si on the left and there is an icon clear all.

Got the same problem. Please check if language file you have selected is valid json file. You can use jsonlint. For me, it was a ending comma in array, removed that and working now.