Unable to Build Android App - Missing Dependencies

  1. droid > build.gradle

What went wrong:
Could not determine the dependencies of task ‘:app:mergeDebugAssets’.

Could not resolve all task dependencies for configuration ‘:app:debugRuntimeClasspath’.
Could not resolve com.facebook.react:react-native:0.69.+.
Required by:
project :app
project :app > project :react-native-navigation-bar-color
project :app > project :react-native-vector-icons
project :app > project :react-native-async-storage_async-storage
project :app > project :react-native-clipboard_clipboard
project :app > project :react-native-community_datetimepicker
project :app > project :react-native-community_geolocation
project :app > project :react-native-firebase_app
project :app > project :react-native-firebase_messaging
project :app > project :react-native-calendar-events
project :app > project :react-native-camera
project :app > project :react-native-date-picker
project :app > project :react-native-document-picker
project :app > project :react-native-fast-image
project :app > project :react-native-gesture-handler
project :app > project :react-native-pager-view
project :app > project :react-native-permissions
project :app > project :react-native-push-notification
project :app > project :react-native-safe-area-context
project :app > project :react-native-screens
project :app > project :react-native-splash-screen
project :app > project :react-native-svg
project :app > project :react-native-track-player
project :app > project :react-native-version-check
project :app > project :rn-fetch-blob
Failed to list versions for com.facebook.react:react-native.
Unable to load Maven meta-data from https://github.com/jitsi/jitsi-maven-repository/raw/master/releases/com/facebook/react/react-native/maven-metadata.xml.
Could not HEAD ‘https://raw.githubusercontent.com/jitsi/jitsi-maven-repository/master/releases/com/facebook/react/react-native/maven-metadata.xml’.
Connect to raw.githubusercontent.com:443 [raw.githubusercontent.com/49.44.79.236, raw.githubusercontent.com/2405:200:1607:2820:41:0:0:36] failed: connect timed out
Could not resolve org.jitsi.react:jitsi-meet-sdk:5.1.0.
Required by:
project :app > project :react-native-jitsi-meet
Skipped due to earlier error
Could not resolve org.jitsi.react:jitsi-meet-sdk:5.1.0.
Could not get resource ‘https://www.jitpack.io/org/jitsi/react/jitsi-meet-sdk/5.1.0/jitsi-meet-sdk-5.1.0.pom’.
Could not HEAD ‘https://www.jitpack.io/org/jitsi/react/jitsi-meet-sdk/5.1.0/jitsi-meet-sdk-5.1.0.pom’. Received status code 401 from server: Unauthorized

allprojects {
   repositories {
       maven {
           // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
           url("$rootDir/../node_modules/react-native/android")
       }
       maven {
           // Android JSC is installed from npm
           url("$rootDir/../node_modules/jsc-android/dist")
       }
       mavenCentral {
           // We don't want to fetch react-native from Maven Central as there are
           // older versions over there.
           content {
               excludeGroup "com.facebook.react"
           }
       }
       google()
       maven {
           url "https://maven.google.com"
       }
       maven { // <---- Add this block
           url "https://github.com/jitsi/jitsi-maven-repository/raw/master/releases"
       }
       maven { url 'https://www.jitpack.io' }
       jcenter() {
           content {
               includeModule("com.yqritc", "android-scalablevideoview")
           }
       }
   }
}

  1. android > build.gradle;
    What went wrong:
    Could not determine the dependencies of task ‘:app:mergeDebugAssets’.

Could not resolve all task dependencies for configuration ‘:app:debugRuntimeClasspath’.
Could not resolve org.jitsi.react:jitsi-meet-sdk:5.1.0.
Required by:
project :app > project :react-native-jitsi-meet
Could not resolve org.jitsi.react:jitsi-meet-sdk:5.1.0.
Could not parse POM jitsi-maven-repository/jitsi-meet-sdk-5.1.0.pom at master · jitsi/jitsi-maven-repository · GitHub
Already seen doctype.
Could not find com.github.henninghall:numberpickerview:v1.1.5.
Searched in the following locations:
- file:/Users/tushar/react-native/WeConnect/node_modules/react-native/android/com/github/henninghall/numberpickerview/v1.1.5/numberpickerview-v1.1.5.pom
- file:/Users/tushar/react-native/WeConnect/node_modules/jsc-android/dist/com/github/henninghall/numberpickerview/v1.1.5/numberpickerview-v1.1.5.pom
- https://repo.maven.apache.org/maven2/com/github/henninghall/numberpickerview/v1.1.5/numberpickerview-v1.1.5.pom
- https://dl.google.com/dl/android/maven2/com/github/henninghall/numberpickerview/v1.1.5/numberpickerview-v1.1.5.pom
- https://maven.google.com/com/github/henninghall/numberpickerview/v1.1.5/numberpickerview-v1.1.5.pom
- https://github.com/jitsi/jitsi-maven-repository/tree/master/releases/com/github/henninghall/numberpickerview/v1.1.5/numberpickerview-v1.1.5.pom
Required by:
project :app > project :react-native-date-picker
Could not find com.github.DoubleSymmetry:KotlinAudio:v1.2.4.
Searched in the following locations:
- file:/Users/tushar/react-native/WeConnect/node_modules/react-native/android/com/github/DoubleSymmetry/KotlinAudio/v1.2.4/KotlinAudio-v1.2.4.pom
- file:/Users/tushar/react-native/WeConnect/node_modules/jsc-android/dist/com/github/DoubleSymmetry/KotlinAudio/v1.2.4/KotlinAudio-v1.2.4.pom
- https://repo.maven.apache.org/maven2/com/github/DoubleSymmetry/KotlinAudio/v1.2.4/KotlinAudio-v1.2.4.pom
- https://dl.google.com/dl/android/maven2/com/github/DoubleSymmetry/KotlinAudio/v1.2.4/KotlinAudio-v1.2.4.pom
- https://maven.google.com/com/github/DoubleSymmetry/KotlinAudio/v1.2.4/KotlinAudio-v1.2.4.pom
- https://github.com/jitsi/jitsi-maven-repository/tree/master/releases/com/github/DoubleSymmetry/KotlinAudio/v1.2.4/KotlinAudio-v1.2.4.pom
Required by:
project :app > project :react-native-track-player

allprojects {
   repositories {
       maven {
           // All of React Native (JS, Obj-C sources, Android binaries) is installed from npm
           url("$rootDir/../node_modules/react-native/android")
       }
       maven {
           // Android JSC is installed from npm
           url("$rootDir/../node_modules/jsc-android/dist")
       }
       mavenCentral {
           // We don't want to fetch react-native from Maven Central as there are
           // older versions over there.
           content {
               excludeGroup "com.facebook.react"
           }
       }
       google()
       maven {
           url "https://maven.google.com"
       }
       maven { // <---- Add this block
           url "https://github.com/jitsi/jitsi-maven-repository/tree/master/releases"
       }
       // maven { url 'https://www.jitpack.io' }
       jcenter() {
           content {
               includeModule("com.yqritc", "android-scalablevideoview")
           }
       }
   }
}

What versions of node and npm are you running?

@Freddie We are using, node: v16.15.1, npm: 8.11.0

@Freddie, Dear Community I guess anyone wanted to build an Android app would be facing same issue.

Facing same issue