Unable to bind nginx to port 443

I did a quick install of Jitsi Meet in Digital Ocean (Debian 10). The nginx configuration seemed to bind ssl to port 4444 and not 443. When I manually changed it to 443, nginx wont start and would complain port 443 is in use. I did a netstat and strangely I found nginx using port 443. I had to allow port 4444 in ufw to make Jitsi Meet serve to public.

Can you somebody let me know what I am doing wrong please?

dr@yotta:/etc/nginx/sites-available$ sudo netstat -tulpn | grep -E '4444|443'
tcp        0      0 0.0.0.0:443             0.0.0.0:*               LISTEN      828/nginx: master p 
tcp        0      0 0.0.0.0:4444            0.0.0.0:*               LISTEN      828/nginx: master p 
tcp6       0      0 :::443                  :::*                    LISTEN      828/nginx: master p 
tcp6       0      0 :::4444                 :::*                    LISTEN      828/nginx: master p

Nginx listens TCP/443 because of the /etc/nginx/modules-enabled/60-jitsi-meet.conf config. If the incoming request is a HTTP request, redirected to the site (jitsi-meet); if it’s a TURN request, redirected to the coturn server.

This is the normal behaviour when using the usual installation steps.

Hi,

But the jitsi meet frontend is only working at meet.example.com:4444 and not at meet.example.com. In firefox it says, secure connection failed. Any reason why this is happening?

Do you have two Nginx instances?
Could you paste the output?

ps auxww | grep nginx
grep listen /etc/nginx/ -R

I followed the jitsi quick install guide on Debian 10 (digital ocean). Here is the output.

dr@yotta:~$ ps auxww | grep nginx
root      1427  0.0  0.4  81144  8936 ?        Ss   Jul25   0:00 nginx: master process /usr/sbin/nginx -g daemon on; master_process on;
www-data  6147  0.0  0.4 142492 10064 ?        S    Jul26   0:01 nginx: worker process
www-data  6149  0.0  0.2  81144  5148 ?        S    Jul26   0:00 nginx: worker process
dr   14418  0.0  0.0   5812   888 pts/0    S+   17:24   0:00 grep nginx

dr@yotta:~$ grep listen /etc/nginx/ -R
/etc/nginx/nginx.conf:#		listen     localhost:110;
/etc/nginx/nginx.conf:#		listen     localhost:143;
/etc/nginx/sites-enabled/default:	listen 80 default_server;
/etc/nginx/sites-enabled/default:	listen [::]:80 default_server;
/etc/nginx/sites-enabled/default:	# listen 443 ssl default_server;
/etc/nginx/sites-enabled/default:	# listen [::]:443 ssl default_server;
/etc/nginx/sites-enabled/default:#	listen 80;
/etc/nginx/sites-enabled/default:#	listen [::]:80;
/etc/nginx/sites-enabled/meet.example.com.conf:    listen 80;
/etc/nginx/sites-enabled/meet.example.com.conf:    listen [::]:80;
/etc/nginx/sites-enabled/meet.example.com.conf:    listen 4444 ssl http2;
/etc/nginx/sites-enabled/meet.example.com.conf:    listen [::]:4444 ssl http2;
/etc/nginx/modules-enabled/60-jitsi-meet.conf:        listen 443;
/etc/nginx/modules-enabled/60-jitsi-meet.conf:        listen [::]:443;
/etc/nginx/sites-available/default:	listen 80 default_server;
/etc/nginx/sites-available/default:	listen [::]:80 default_server;
/etc/nginx/sites-available/default:	# listen 443 ssl default_server;
/etc/nginx/sites-available/default:	# listen [::]:443 ssl default_server;
/etc/nginx/sites-available/default:#	listen 80;
/etc/nginx/sites-available/default:#	listen [::]:80;
/etc/nginx/sites-available/meet.example.com.conf:    listen 80;
/etc/nginx/sites-available/meet.example.com.conf:    listen [::]:80;
/etc/nginx/sites-available/meet.example.com.conf:    listen 4444 ssl http2;
/etc/nginx/sites-available/meet.example.com.conf:    listen [::]:4444 ssl http2;
/etc/nginx/sites-available/meet.example.com.conf.old:    listen 80;
/etc/nginx/sites-available/meet.example.com.conf.old:    listen [::]:80;
/etc/nginx/sites-available/meet.example.com.conf.old:    listen 4444 ssl http2;
/etc/nginx/sites-available/meet.example.com.conf.old:    listen [::]:4444 ssl http2;

P.S: I have replaced the domain.

Everything seems OK. I couldn’t figure out what is going on