Unable to activate anonymous domain

Hi,
As new user I am unable to post link. I modified all http and https link.

I installed Jitsi using this istructions (.-jitsi.org/downloads/) and was able to configure application with authenticated domain (internal_plain). When I connect to meet I can login and create a room.
Now I want to configure a guest domain with anonymous auth. I found this instructions (–github.com/jitsi/jicofo) in secure domain paragraph for Debian package installation.

I restart all service after I modify configuration files.

Now when I connect to secure domain (–auth.mydomain.com) no more receive login prompt, but connection restart in loop.

I put prosody log in debug mode and noticed that when I connect to secure domain jitsi seem to attempt to call anonymous domain, not secure domain

Note: I changed real hostname for privacy reasons

I call from browser secure domain
–auth.mydomain.com
then make a room

With anonymous domain active application disconnect and reconnect in a loop.

In prosody log I found
Jan 18 11:25:07 c2s559e0bce14f0 debug Received[c2s]: <iq id=‘izajk-1244’ type=‘get’ to=’<–guest.mydomain.com’>
Jan 18 11:25:15 mod_bosh debug Handling new request table: 0x559e0bad0230: <body rid=‘3092255628’ xmlns=‘jabber.org/protocol/httpbind’ to=‘guest.mydomain.com’ xml:lang=‘en’ wait=‘60’ hold=‘1’ content=‘text/xml; charset=utf-8’ ver=‘1.6’ xmpp:version=‘1.0’ xmlns:xmpp=‘urn:xmpp:xbosh’/>

But --guest.mydomain.com is not correct… The correct domain is --auth.mydomain.com.

In browser console:
[JitsiMeetJS.js] <getGlobalOnErrorHandler>: UnhandledError: null Script: null Line: null Column: null StackTrace: Error: “Strophe: Server did not offer a supported authentication mechanism”

The only configuration change when anonymous domain is active are:

prosody adding anonymous virtual host:

VirtualHost “–guest.mydomain.com”
ssl = {
key = “/etc/prosody/certs/guest.mydomain.com.key”;
certificate = “/etc/prosody/certs/guest.mydomain.com.crt”;
}
authentication = “anonymous”
c2s_require_encryption = false

meet uncomment anonymousdomain line adding correct guest hostname:
// When using authentication, domain for guest users.
anonymousdomain: ‘–guest.mydomain.com’,

If I disable in meet configuration anonymousdomain line all restart to go well, but only in secure domain.

I missing other configurations ?

Thanks in advance
Giorgio

Resolved using docker version