Unable to access camera: Logitech ConferenceCam Connect.+ Win8.1 + Chrome

meet

#1

When i enter a Jitsi meeting with Logitech ConferenceCam Connect on win 8.1 and Chrome last version (Versione 70.0.3538.77), i receive the error unable to access camera.

All the camera’s access are granted to the jitsi server site.

If i try other applications or other websites on chrome that use the camera, evertyhing it’s ok.
The same camera on a PC with windows 10 and the same chrome version works properly.

The same happens with camera Logitech C930e.

Could you help me?


#2

That cameras are working fine on Firefox on the same PC with win 8.1, but we need Chrome to use descktop sharing extension.


#3

Can you test your camera with this site? https://test.webrtc.org/ If it works there it should work with Jitsi, if it doesn’t… then there is little we can do.

PS: You are not spoofing the UserAgent, right?


#4

On https://test.webrtc.org/ the camera works.
The last solution is to upgrade Windows from 8 to 10.


#5

Hum, that’s interesting. If it works there, it should also work on Jitsi. I don’t think updating Windows would solve anything.

Are you using meet.jit.si or your own server? At any rate, please paste the JavaScript console logs when this happens and let’s see if we can track it down.


#6

We tested with meet.jit.si and didn’t worked.
We’ll try to grab the javascript console logs.
The user connected the same camera to a PC with Windows 10 within the same LAN and all worked flawlessy.


#7

Also on meet? Then maybe there is some weird corner case… if upgrading to Window 10 is an option for you then maybe that’s the shortest path here. Also it’s much better than 8 :stuck_out_tongue: