Unable do disable autologin using Docker Installation

Hi, I’m using the latest stable version of Jitsi Docker and I’m trying to disable autologin, with no success at all. I tried every suggestion that people gave in the forum, even using the DISABLE_AUTOLOGIN variable. Is there an alternative to disable persistent login when using LDAP authentication?

LOG INFO:

INFO: Starting authentication service with config=AuthConfig[enabled=true, type=XMPP, loginUrl=meet.jitsi, logoutUrl=null, authenticationLifetime=PT24H, enableAutoLogin=true]
2021-04-27T14:33:17.647876339Z INFO: Initialized newConfig: merge of /config/jicofo.conf: 1,system properties,reference.conf @ jar:file:/usr/share/jicofo/jicofo.jar!/reference.conf: 1

jicofo.conf :

jicofo {

authentication {
  enabled = true
  // The type of authentication. Supported values are XMPP, JWT or SHIBBOLETH (default).
  
  type = XMPP
  
  
  login-url = "meet.jitsi"
  enable-auto-login = false
  
}


// Configuration related to jitsi-videobridge
bridge {
  

  

  

  

  

  brewery-jid = "jvbbrewery@internal-muc.meet.jitsi"
}
// Configure the codecs and RTP extensions to be used in the offer sent to clients.
codec {
  video {
    
    
    
  }
}

conference {
  

  

  
}







octo {
  // Whether or not to use Octo. Note that when enabled, its use will be determined by
  // $jicofo.bridge.selection-strategy. There's a corresponding flag in the JVB and these
  // two MUST be in sync (otherwise bridges will crash because they won't know how to
  // deal with octo channels).
  enabled = false
  
  id = "1"
}

sctp {
  enabled = false
}

xmpp {
  client {
    enabled = true
    hostname = "xmpp.meet.jitsi"
    domain = "auth.meet.jitsi"
    username = "focus"
    password = "4c4bad388bf3cc6270bed9f5831d792e"  
    conference-muc-jid = "muc.meet.jitsi"
    client-proxy = "focus.meet.jitsi"
    disable-certificate-verification = true
  }
}

}

1 Like

I had the same problem too. what version of your installed docker jitsi? I have resolve this problem by myself.

version: docker-jitsi-meet-stable-6173
problem: can not configure the auto login option in .env file.
resolved:

1, modify the docker-compose.xml, build jicofo from the Dockerfile:
add line after image: jitsi/jicofo:custom-stable-6173

    jicofo:
        image: jitsi/jicofo:custom-stable-6173
        build: ./jicofo
        restart: ${RESTART_POLICY}

2, add a line “enable-auto-login=false” to jicofo/rootfs/defaults/jicofo.conf:

    {{ if $ENABLE_AUTH }}
    authentication {
      enabled = true
      // The type of authentication. Supported values are XMPP, JWT or SHIBBOLETH (default).
      {{ if eq $AUTH_TYPE "jwt" }}
      type = JWT
      {{ else if eq $AUTH_TYPE "shibboleth" }}
      type = SHIBBOLETH
      {{ else }}
      type = XMPP
      {{ end }}
      {{ if eq $AUTH_TYPE "shibboleth" }}
      login-url = "shibboleth:default"
      logout-url = "shibboleth:default"
      {{ else }}
      login-url = "{{ .Env.XMPP_DOMAIN }}"
      {{ end }}
      enable-auto-login=false
    }
    {{ end }}

3、build and start jitsi docker compose:

docker-compose up --build -d

I think this should only be a temporary solution before the developer of jitsi add this option support to docker-jitsi.

1 Like

I’ve submit a pull request to fix this problem.

1 Like

Thank you!! It works!