Udate Jitsi to the latest on Ubuntu 20.04 LTS

Thinking my system whas updated untill I see this with the latest update:

The following packages have unmet dependencies:
jitsi-meet-prosody : Depends: prosody (>= 0.11.7) but 0.11.4-1 is to be installed or
prosody-trunk but it is not installable or
prosody-0.12 but it is not installable or
prosody-0.11 but it is not installable
E: Unable to correct problems, you have held broken packages.

Does I need to reinstall jitsi? I hope not

What is the output for

apt-cache policy prosody
apt show prosody | head

Same problem, can’t update

jitsi-meet-prosody package has a dependency to prosody package which is newer than 0.11.7 but your system can only provide prosody version 0.11.4-1.

The following packages have unmet dependencies:
jitsi-meet-prosody : Depends: prosody (>= 0.11.7) but 0.11.4-1 is to be installed
  • You may upgrade your distro which provides a newer version of prosody from its own official repo
  • or you can add a third-party repo to your system which provides a newer version of prosody
1 Like

add-the-prosody-package-repository

Thanks, that fixed it

@emrah

Thanks, the solution to install prosody did his work well

In mean time I found a solution for version NGINX version 1.18 who doesn’t allow to share port 443.
In this link you find a nice script which install NGINX version 1.22 with LUA support and some other stuff.
Use first sudo apt remove nginx-common before using this script.

You can share port 443 with the help of a second DNS, here is how to do that for the turnserver Setting up TURN | Jitsi Meet

@damencho,

When I had NGINX 1.18 i did everything possible to get the port 443 shared and had to make for each https website a other port.
Now with NGINX 1.22 concerning this issue everything works fine.

That is strange the option is supported since 1.11.5
http://nginx.org/en/docs/stream/ngx_stream_ssl_preread_module.html