Ubuntu 20.4 changing To new static address

Hi, I am changeing my ISP and will now have a static address that I can point at.

Rather than do a complete re-install I would like to just amend the configuration files.

I will be trying to to do it with reference to the server install instructions but am not that confident that I will miss something!

Could someone please point me to relevant information or list the files i need to change?

FWIW ATM I use Duckddns to point to my IP address and check evrey few minutes for changes.

Thanks

When public address change you need to edit jvb.conf if it is there … or if you are using the stun harvester just restart jvb when IP address changes.

Assuming its just jvb.conf and also change everywhere the old IP address is listed, I assume I will need a new cert for the address?
I am not sure (yet) what I have in hosts, do I have to add the url as I don’t remember configuring it when I installed Jitsi!?

Thanks

Jvb is the only one that needs the ip address. Everything else is based on the DNS name and does not depend on the ip address.

Hi,
Apologies, I have only just started to change my ISP and have pointed my DuckDNS at my new IP, but it does not yet work as I cannot find info on JVP.

Could you please give me a link to its config?

Thanks

Peter H

Depending on the installation, your old IP could be inside /etc/hosts

Did you restart jvb? Or if you have setup ip manually change it before restart

FYI I am not an expert at setting up a server and set it up on Ubuntu 20.4 and used their quick install, I had to use a dns server as it was a dynamic IP address.
I have now configured “duckdns.org” to my new static IP address and I need to change something on Jitsi Server to enable it to run on my new IP address.
Looking in my /etc/hosts there was no reference to my old IP address so I have not added anything!
During searching I have found references to “jvp” and “jvb”, are these the same or different!?

I have not restarted any separate s/w but have rebooted and with the server running I do not get anything on a browser using Chromuim on a laptop.

Exactly what do I need to configure to make Jitsi work again?

Thanks

Peter H

Can you share the files in /etc/jitsi/jvb
sip-communicator.properties and jvb.conf
Mask any sensitive information like domains and password/secrets

Here is what I have:
root@c3:/etc/jitsi/videobridge# ls
callstats-java-sdk.properties jvb.conf logging.properties
config log4j2.xml sip-communicator.properties
root@c
3:/etc/jitsi/videobridge# cat jvb.conf
videobridge {
http-servers {
public {
port = 9090
}
}
websockets {
enabled = true
domain = "c123.duckdns.org:443"
tls = true
}
}
root@c
3:/etc/jitsi/videobridge# cat sip-communicator.properties
org.ice4j.ice.harvest.DISABLE_AWS_HARVESTER=true
org.ice4j.ice.harvest.STUN_MAPPING_HARVESTER_ADDRESSES=meet-jit-si-turnrelay.jitsi.net:443
org.jitsi.videobridge.ENABLE_STATISTICS=true
org.jitsi.videobridge.STATISTICS_TRANSPORT=muc
org.jitsi.videobridge.xmpp.user.shard.HOSTNAME=localhost
org.jitsi.videobridge.xmpp.user.shard.DOMAIN=auth.c3.duckdns.org
org.jitsi.videobridge.xmpp.user.shard.USERNAME=jvb
org.jitsi.videobridge.xmpp.user.shard.PASSWORD=kJHSAF**
org.jitsi.videobridge.xmpp.user.shard.MUC_JIDS=JvbBrewery@internal.auth.3.duckdns.org
org.jitsi.videobridge.xmpp.user.shard.MUC_NICKNAME=667ac67c-88b9-40bb-80c2-984346a9

root@c
3:/etc/jitsi/videobridge#

So when the public ip address changes, you only need to restart jvb and it will take the new address and start using it.

Hi,
It still cannot find the server, says it might be down etc, but I have just done a ping and its on my new IP address!:
[peter@new-laptop ~]$ ping r123.duckdns.org
PING r123.duckdns.org (78..253.10) 56(84) bytes of data.
64 bytes from lns3.inx.dsl.enta.net (78.
.253.10): icmp_seq=1 ttl=254 time=10.4 ms
64 bytes from lns3.inx.dsl.enta.net (78.
.253.10): icmp_seq=2 ttl=254 time=10.5 ms
64 bytes from lns3.inx.dsl.enta.net (78..253.10): icmp_seq=3 ttl=254 time=11.5 ms
64 bytes from lns3.inx.dsl.enta.net (78.
.253.10): icmp_seq=4 ttl=254 time=11.2 ms
^C
— ****r123.duckdns.org ping statistics —
4 packets transmitted, 4 received, 0% packet loss, time 3005ms
rtt min/avg/max/mdev = 10.368/10.904/11.485/0.469 ms
[peter@new-laptop ~]$

Will have another look tomorrow night, but any ideas welcome.

Thanks

Peter H

I have juust realized that I have had to change my router when i changed my ISP recently!
It is a while since installing Jitsi server, do I need to set up my new router to forward ports!?

Thanks

PS had a look at install instructions and cannot find any errors but still no Jitsi login page but services are running.

Peter H

is there any way to auto update this ip in jvb.conf when the public ip is changed?
Thanks!

You can use the stun mapping harvester jitsi-videobridge/postinst at 1117daf171171a82186b02c114c405c7349c4c50 · jitsi/jitsi-videobridge · GitHub
and just restart jvb everytime the ip address changes.