Ubuntu 20.04 installation error The following packages have unmet dependencies

I have tried to install jitsi-meet in ubuntu 20.04 using the following steps codes

  1. sudo wget -q0 https://download.jitsi.org/jitsi-key.gpg.key | apt-key add
  2. echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list
  3. apt update
  4. apt install jitsi-meet

But it keeps on giving me the following error even after reinstalling the OS more than 3 times

The following packages have unmet dependencies: jitsi-meet : Depends: jicofo (= 1.0-940-1) but it is not going to be installed Depends: jitsi-meet-prosody (= 1.0.6644-1) but it is not going to be installed Recommends: jitsi-meet-turnserver (= 1.0.6644-1) but it is not going to be installed E: Unable to correct problems, you have held broken packages.

Please I would appreciate whatever help that can be rendered for me to continue my project.
Thanks

Add prosody repo first:

These are the steps I took and this is the result.

Firewall is active and enabled on system startup, i also enabled https, http and udp
root@ubuntu:~# ufw allow in ssh

Rule added
Rule added (v6)
root@ubuntu:~# echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list
deb http://packages.prosody.im/debian focal main
root@ubuntu:~# wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -
--2022-10-24 09:15:06--  https://prosody.im/files/prosody-debian-packages.key
Resolving prosody.im (prosody.im)... 46.43.15.35, 2001:41c9:1:424::35
Connecting to prosody.im (prosody.im)|46.43.15.35|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1686 (1.6K) [application/octet-stream]
Saving to: ‘STDOUT’

-                   100%[===================>]   1.65K  --.-KB/s    in 0s      

2022-10-26 14:15:07 (162 MB/s) - written to stdout [1686/1686]

OK
root@ubuntu:~# apt install lua5.2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package lua5.2
E: Couldn't find any package by glob 'lua5.2'
root@ubuntu:~# 
root@ubuntu:~# wget https://download.jitsi.org/jitsi-key.gpg.key | apt-key add
--2022-10-26 14:16:14--  https://download.jitsi.org/jitsi-key.gpg.key
Resolving download.jitsi.org (download.jitsi.org)... 35.161.96.31, 34.209.97.49, 2600:1f14:5eb:f801:730b:cd02:ffec:70cb, ...
Connecting to download.jitsi.org (download.jitsi.org)|35.161.96.31|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3114 (3.0K) [application/octet-stream]
Saving to: ‘jitsi-key.gpg.key’

jitsi-key.gpg.key   100%[===================>]   3.04K  --.-KB/s    in 0s      

2022-10-26 14:16:17 (172 MB/s) - ‘jitsi-key.gpg.key’ saved [3114/3114]

gpg: no valid OpenPGP data found.
root@ubuntu:~# 
root@ubuntu:~# wget https://download.jitsi.org/jitsi-key.gpg.key
--2022-10-26 14:16:42--  https://download.jitsi.org/jitsi-key.gpg.key
Resolving download.jitsi.org (download.jitsi.org)... 35.161.96.31, 34.209.97.49, 2600:1f14:5eb:f801:730b:cd02:ffec:70cb, ...
Connecting to download.jitsi.org (download.jitsi.org)|35.161.96.31|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3114 (3.0K) [application/octet-stream]
Saving to: ‘jitsi-key.gpg.key.1’

jitsi-key.gpg.key.1 100%[===================>]   3.04K  --.-KB/s    in 0s      

2022-10-26 14:16:44 (32.8 MB/s) - ‘jitsi-key.gpg.key.1’ saved [3114/3114]

root@ubuntu:~# 
root@ubuntu:~# apt-key add jitsi-key.gpg.key
OK
root@ubuntu:~# echo 'deb https://download.jitsi.org stable/' > /etc/apt/sources.list.d/jitsi-stable.list
root@ubuntu:~# apt update
Ign:1 cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal InRelease
Hit:2 cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal Release
Get:4 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]      
Hit:5 http://archive.ubuntu.com/ubuntu focal InRelease                         
Get:6 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]        
Get:7 http://packages.prosody.im/debian focal InRelease [7275 B]               
Get:8 https://download.jitsi.org stable/ InRelease [1682 B]                    
Get:9 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [2194 kB]
Get:10 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages [1818 kB]
Get:11 http://packages.prosody.im/debian focal/main amd64 Packages [1825 B]    
Get:12 https://download.jitsi.org stable/ Packages [72.0 kB]                   
Get:13 http://security.ubuntu.com/ubuntu focal-security/main Translation-en [300 kB]
Get:14 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [40.7 kB]
Get:15 http://security.ubuntu.com/ubuntu focal-security/main DEP-11 48x48 Icons [18.3 kB]
Get:16 http://security.ubuntu.com/ubuntu focal-security/main DEP-11 64x64 Icons [35.5 kB]
Get:17 http://security.ubuntu.com/ubuntu focal-security/main amd64 c-n-f Metadata [11.2 kB]
Get:18 http://archive.ubuntu.com/ubuntu focal-updates/main Translation-en [385 kB]
Get:19 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [275 kB]
Get:20 http://archive.ubuntu.com/ubuntu focal-updates/main DEP-11 48x48 Icons [60.8 kB]
Get:21 http://archive.ubuntu.com/ubuntu focal-updates/main DEP-11 64x64 Icons [98.3 kB]
Get:22 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 Packages [1282 kB]
Get:23 http://security.ubuntu.com/ubuntu focal-security/restricted Translation-en [182 kB]
Get:24 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 c-n-f Metadata [16.0 kB]
Get:25 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 Packages [1378 kB]
Get:26 http://security.ubuntu.com/ubuntu focal-security/restricted amd64 c-n-f Metadata [596 B]
Get:27 http://archive.ubuntu.com/ubuntu focal-updates/restricted Translation-en [195 kB]
Get:28 http://archive.ubuntu.com/ubuntu focal-updates/restricted amd64 c-n-f Metadata [600 B]
Fetched 8602 kB in 43s (198 kB/s)                                              
Error: Timeout was reached
Reading package lists... Done
Building dependency tree       
Reading state information... Done
519 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@ubuntu:~# apt update
Ign:1 cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal InRelease
Hit:2 cdrom://Ubuntu 20.04.3 LTS _Focal Fossa_ - Release amd64 (20210819) focal Release
Hit:4 http://packages.prosody.im/debian focal InRelease                                                      
Hit:5 http://archive.ubuntu.com/ubuntu focal InRelease                                         
Hit:6 http://archive.ubuntu.com/ubuntu focal-updates InRelease                            
Hit:7 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:8 https://download.jitsi.org stable/ InRelease         
Reading package lists... Done                      
Building dependency tree       
Reading state information... Done
519 packages can be upgraded. Run 'apt list --upgradable' to see them.
root@ubuntu:~# 
root@ubuntu:~# apt -y install jitsi-meet
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 jitsi-meet : Depends: jicofo (= 1.0-940-1) but it is not going to be installed
              Depends: jitsi-meet-prosody (= 1.0.6644-1) but it is not going to be installed
              Recommends: jitsi-meet-turnserver (= 1.0.6644-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
  1. Please what could be the problem and how can i solve it.

  2. Also in the tutorial I saw that u used nginx, but my server is using apache, is the process for nginx different from that of apache?

So I created an empty VM and tried it out. So this error with lua is strange …

root@test1:~# lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.4 LTS
Release:	20.04
Codename:	focal
Hit:1 http://security.ubuntu.com/ubuntu focal-security InRelease
Hit:2 http://mirrors.digitalocean.com/ubuntu focal InRelease
Hit:3 http://mirrors.digitalocean.com/ubuntu focal-updates InRelease
Hit:4 http://mirrors.digitalocean.com/ubuntu focal-backports InRelease
Get:5 http://packages.prosody.im/debian focal InRelease [7275 B]
Hit:6 https://repos-droplet.digitalocean.com/apt/droplet-agent main InRelease
Get:7 http://packages.prosody.im/debian focal/main amd64 Packages [1825 B]
Get:8 https://download.jitsi.org stable/ InRelease [1682 B]
Get:9 https://download.jitsi.org stable/ Packages [72.0 kB]
Fetched 82.8 kB in 3s (28.4 kB/s)
Reading package lists...
Building dependency tree...
Reading state information...
80 packages can be upgraded. Run 'apt list --upgradable' to see them.

WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
  lua5.2
0 upgraded, 1 newly installed, 0 to remove and 80 not upgraded.
Need to get 99.8 kB of archives.
After this operation, 370 kB of additional disk space will be used.
Get:1 http://mirrors.digitalocean.com/ubuntu focal/universe amd64 lua5.2 amd64 5.2.4-1.1build3 [99.8 kB]
root@test1:~# apt show lua5.2
Package: lua5.2
Version: 5.2.4-1.1build3
Priority: optional
Section: universe/interpreters
Origin: Ubuntu
Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Original-Maintainer: Enrico Tassi <gareuselesinge@debian.org>
Bugs: https://bugs.launchpad.net/ubuntu/+filebug
Installed-Size: 370 kB
Provides: lua
Depends: libc6 (>= 2.29), libreadline8 (>= 6.0)
Homepage: http://www.lua.org
Download-Size: 99.8 kB
APT-Manual-Installed: yes
APT-Sources: http://mirrors.digitalocean.com/ubuntu focal/universe amd64 Packages
Description: Simple, extensible, embeddable programming language
 Lua is a powerful, light-weight programming language designed for extending
 applications.  The language engine is accessible as a library, having a C
 API which allows the application to exchange data with Lua programs and also
 to extend Lua with C functions.  Lua is also used as a general-purpose,
 stand-alone language through the simple command line interpreter provided.
 .
 This package contains the Lua command line interpreter and bytecode compiler.
 Install it if you are developing or using Lua scripts.

I think you are missing universe from the apt sources

I had to use a ubuntu 2022.04 yet I am still getting error.
The detail of what I have done are below.

Please note that wherever you see ---------------- it depicts that I am separating my command from next command that I gave

sudo apt update 
ubuntu@ubuntu:~/Desktop/tor-browser_en-US/Browser$ sudo apt update
Ign:1 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease
Hit:2 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy Release
Get:3 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
Get:5 http://security.ubuntu.com/ubuntu jammy-security/main amd64 Packages [461 kB]
Get:6 http://security.ubuntu.com/ubuntu jammy-security/main Translation-en [101 kB]
Get:7 http://security.ubuntu.com/ubuntu jammy-security/main amd64 DEP-11 Metadata [20.0 kB]
Get:8 http://security.ubuntu.com/ubuntu jammy-security/main DEP-11 48x48 Icons [13.2 kB]
Get:9 http://security.ubuntu.com/ubuntu jammy-security/main DEP-11 64x64 Icons [22.1 kB]
Get:10 http://security.ubuntu.com/ubuntu jammy-security/restricted amd64 Packages [372 kB]
Get:11 http://security.ubuntu.com/ubuntu jammy-security/restricted Translation-en [57.4 kB]
Hit:12 http://archive.ubuntu.com/ubuntu jammy InRelease                        
Get:13 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]       
Get:14 http://archive.ubuntu.com/ubuntu jammy/main amd64 Packages [1395 kB]    
Get:15 http://archive.ubuntu.com/ubuntu jammy/restricted amd64 Packages [129 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 Packages [695 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy-updates/main Translation-en [159 kB]
Get:18 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 DEP-11 Metadata [95.1 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy-updates/main DEP-11 48x48 Icons [26.7 kB]
Get:20 http://archive.ubuntu.com/ubuntu jammy-updates/main DEP-11 64x64 Icons [41.8 kB]
Get:21 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 c-n-f Metadata [10.8 kB]
Get:22 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 Packages [409 kB]
Get:23 http://archive.ubuntu.com/ubuntu jammy-updates/restricted Translation-en [63.1 kB]
Get:24 http://archive.ubuntu.com/ubuntu jammy-updates/restricted amd64 c-n-f Metadata [540 B]
Fetched 4297 kB in 1min 3s (68.3 kB/s)                                         
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
250 packages can be upgraded. Run 'apt list --upgradable' to see them.

---------------------------------------
sudo apt install apt-transport-https

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'apt' instead of 'apt-transport-https'
The following additional packages will be installed:
  apt-utils libapt-pkg6.0
Suggested packages:
  apt-doc aptitude | synaptic | wajig dpkg-dev
The following packages will be upgraded:
  apt apt-utils libapt-pkg6.0
3 upgraded, 0 newly installed, 0 to remove and 247 not upgraded.
Need to get 2497 kB of archives.
After this operation, 4096 B of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 libapt-pkg6.0 amd64 2.4.8 [907 kB]
Get:2 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 apt amd64 2.4.8 [1379 kB]
Get:3 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 apt-utils amd64 2.4.8 [211 kB]
Fetched 2497 kB in 7s (378 kB/s)                                               
(Reading database ... 206909 files and directories currently installed.)
Preparing to unpack .../libapt-pkg6.0_2.4.8_amd64.deb ...
Unpacking libapt-pkg6.0:amd64 (2.4.8) over (2.4.6) ...
Setting up libapt-pkg6.0:amd64 (2.4.8) ...
(Reading database ... 206909 files and directories currently installed.)
Preparing to unpack .../archives/apt_2.4.8_amd64.deb ...
Unpacking apt (2.4.8) over (2.4.6) ...
Setting up apt (2.4.8) ...
(Reading database ... 206909 files and directories currently installed.)
Preparing to unpack .../apt-utils_2.4.8_amd64.deb ...
Unpacking apt-utils (2.4.8) over (2.4.6) ...
Setting up apt-utils (2.4.8) ...
Processing triggers for man-db (2.10.2-1) ...
Processing triggers for libc-bin (2.35-0ubuntu3.1) ...

---------------------------

		adding universe gave me some error
		
sudo apt-add-repository universe
Adding component(s) 'universe' to all repositories.
Press [ENTER] to continue or Ctrl-c to cancel.
Added universe to: deb cdrom:[Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1)]/ jammy universe restricted main
Added universe to: deb http://archive.ubuntu.com/ubuntu/ jammy universe restricted main
Added universe to: deb http://security.ubuntu.com/ubuntu/ jammy-security universe restricted main
Added universe to: deb http://archive.ubuntu.com/ubuntu/ jammy-updates universe restricted main
Ign:1 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease
Hit:2 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy Release
Hit:4 http://security.ubuntu.com/ubuntu jammy-security InRelease
Get:5 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 Packages [602 kB]
Hit:6 http://archive.ubuntu.com/ubuntu jammy InRelease                         
Hit:7 http://archive.ubuntu.com/ubuntu jammy-updates InRelease                 
Get:8 http://archive.ubuntu.com/ubuntu jammy/universe amd64 Packages [14.1 MB]
Get:9 http://security.ubuntu.com/ubuntu jammy-security/universe Translation-en [76.4 kB]
Get:10 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 DEP-11 Metadata [13.3 kB]
Get:11 http://security.ubuntu.com/ubuntu jammy-security/universe DEP-11 48x48 Icons [5769 B]
Get:12 http://security.ubuntu.com/ubuntu jammy-security/universe DEP-11 64x64 Icons [12.3 kB]
Get:13 http://security.ubuntu.com/ubuntu jammy-security/universe DEP-11 64x64@2 Icons [29 B]
Get:14 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 c-n-f Metadata [2408 B]
Get:15 http://archive.ubuntu.com/ubuntu jammy/universe Translation-en [5652 kB]
Get:16 http://archive.ubuntu.com/ubuntu jammy/universe amd64 DEP-11 Metadata [3559 kB]
Get:17 http://archive.ubuntu.com/ubuntu jammy/universe DEP-11 48x48 Icons [3447 kB]
Get:18 http://archive.ubuntu.com/ubuntu jammy/universe DEP-11 64x64 Icons [7609 kB]
Get:19 http://archive.ubuntu.com/ubuntu jammy/universe DEP-11 64x64@2 Icons [69.3 kB]
Get:20 http://archive.ubuntu.com/ubuntu jammy/universe amd64 c-n-f Metadata [286 kB]
Get:21 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 Packages [743 kB]
Get:22 http://archive.ubuntu.com/ubuntu jammy-updates/universe Translation-en [122 kB]
Get:23 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 DEP-11 Metadata [255 kB]
Get:24 http://archive.ubuntu.com/ubuntu jammy-updates/universe DEP-11 48x48 Icons [156 kB]
Get:25 http://archive.ubuntu.com/ubuntu jammy-updates/universe DEP-11 64x64 Icons [237 kB]
Get:26 http://archive.ubuntu.com/ubuntu jammy-updates/universe DEP-11 64x64@2 Icons [29 B]
Get:27 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 c-n-f Metadata [4404 B]
Fetched 36.9 MB in 58s (641 kB/s)                                              
Reading package lists... Done
W: Skipping acquire of configured file 'universe/binary-amd64/Packages' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/i18n/Translation-en' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/Components-amd64.yml' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-48x48.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-64x64.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-64x64@2.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/cnf/Commands-amd64' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)

---------

I also got some error during the update

sudo apt update
Ign:1 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease
Hit:2 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy Release
Hit:4 http://security.ubuntu.com/ubuntu jammy-security InRelease                          
Hit:5 http://archive.ubuntu.com/ubuntu jammy InRelease                                    
Hit:6 http://archive.ubuntu.com/ubuntu jammy-updates InRelease
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
247 packages can be upgraded. Run 'apt list --upgradable' to see them.
W: Skipping acquire of configured file 'universe/binary-amd64/Packages' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/i18n/Translation-en' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/Components-amd64.yml' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-48x48.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-64x64.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-64x64@2.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/cnf/Commands-amd64' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)

-----------------
sudo hostnamectl set-hostname mydomainname.com
-----------------
sudo nano /etc/hosts
-----------
echo deb http://packages.prosody.im/debian $(lsb_release -sc) main | sudo tee -a /etc/apt/sources.list
deb http://packages.prosody.im/debian jammy main
-------------------
wget https://prosody.im/files/prosody-debian-packages.key -O- | sudo apt-key add -
--2022-10-28 12:18:39--  https://prosody.im/files/prosody-debian-packages.key
Resolving prosody.im (prosody.im)... 46.43.15.35, 2001:41c9:1:424::35
Connecting to prosody.im (prosody.im)|46.43.15.35|:443... connected.
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d instead (see apt-key(8)).
HTTP request sent, awaiting response... 200 OK
Length: 1686 (1.6K) [application/octet-stream]
Saving to: ‘STDOUT’

-                                                                100%[=========================================================================================================================================================>]   1.65K  --.-KB/s    in 0s      

2022-10-28 12:18:40 (326 MB/s) - written to stdout [1686/1686]

OK
--------------------------
apt install lua5.2
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
---------------
sudo apt install lua5.2
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following NEW packages will be installed:
  lua5.2
0 upgraded, 1 newly installed, 0 to remove and 247 not upgraded.
Need to get 129 kB of archives.
After this operation, 374 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu jammy/universe amd64 lua5.2 amd64 5.2.4-2 [129 kB]
Fetched 129 kB in 1s (153 kB/s)
Selecting previously unselected package lua5.2.
(Reading database ... 206909 files and directories currently installed.)
Preparing to unpack .../lua5.2_5.2.4-2_amd64.deb ...
Unpacking lua5.2 (5.2.4-2) ...
Setting up lua5.2 (5.2.4-2) ...
update-alternatives: using /usr/bin/lua5.2 to provide /usr/bin/lua (lua-interpreter) in auto mode
update-alternatives: using /usr/bin/luac5.2 to provide /usr/bin/luac (lua-compiler) in auto mode
Processing triggers for man-db (2.10.2-1) ...
------------------------
	I used curl it gave me error then had to use wget
wget https://download.jitsi.org/jitsi-key.gpg.key | sudo sh -c 'gpg --dearmor > /usr/share/keyrings/jitsi-keyring.gpg'
--2022-10-28 12:25:10--  https://download.jitsi.org/jitsi-key.gpg.key

Resolving download.jitsi.org (download.jitsi.org)... 34.209.97.49, 35.161.96.31, 2600:1f14:5eb:f801:730b:cd02:ffec:70cb, ...
Connecting to download.jitsi.org (download.jitsi.org)|34.209.97.49|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3114 (3.0K) [application/octet-stream]
Saving to: ‘jitsi-key.gpg.key’

jitsi-key.gpg.key                                                100%[=========================================================================================================================================================>]   3.04K  --.-KB/s    in 0s      

2022-10-28 12:25:14 (348 MB/s) - ‘jitsi-key.gpg.key’ saved [3114/3114]

gpg: no valid OpenPGP data found.
---------------------
echo 'deb [signed-by=/usr/share/keyrings/jitsi-keyring.gpg] https://download.jitsi.org stable/' | sudo tee /etc/apt/sources.list.d/jitsi-stable.list > /dev/null
----------------------
sudo apt update

Ign:1 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease
Hit:2 cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy Release
Hit:4 http://archive.ubuntu.com/ubuntu jammy InRelease                                                                                                                          
Get:5 http://archive.ubuntu.com/ubuntu jammy-updates InRelease [114 kB]                                                                                                         
Get:6 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]                                                           
Get:7 http://packages.prosody.im/debian jammy InRelease [7275 B]                                                                                                                                                                                                  
Get:8 http://archive.ubuntu.com/ubuntu jammy-updates/universe amd64 DEP-11 Metadata [254 kB]                                                                                                                                                                      
Get:9 http://security.ubuntu.com/ubuntu jammy-security/universe amd64 DEP-11 Metadata [13.2 kB]                                                                                                                                                                   
Get:10 http://packages.prosody.im/debian jammy/main amd64 Packages [1517 B]                                                                                                                                                                                       
Get:11 http://archive.ubuntu.com/ubuntu jammy-updates/main amd64 DEP-11 Metadata [95.1 kB]                                                                                                                                                                        
Get:12 http://security.ubuntu.com/ubuntu jammy-security/main amd64 DEP-11 Metadata [20.1 kB]                                                                                                                                                                      
Get:13 https://download.jitsi.org stable/ InRelease [1682 B]                                                                                                                                                                                                      
Err:13 https://download.jitsi.org stable/ InRelease                                                                                                                                                                                                               
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4D2D754E4DC7485
Reading package lists... Done                                                                                                                                                                                                                                     
W: Skipping acquire of configured file 'universe/binary-amd64/Packages' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/i18n/Translation-en' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/Components-amd64.yml' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-48x48.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-64x64.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/dep11/icons-64x64@2.tar' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: Skipping acquire of configured file 'universe/cnf/Commands-amd64' as repository 'cdrom://Ubuntu 22.04.1 LTS _Jammy Jellyfish_ - Release amd64 (20220809.1) jammy InRelease' doesn't have the component 'universe' (component misspelt in sources.list?)
W: http://packages.prosody.im/debian/dists/jammy/InRelease: Key is stored in legacy trusted.gpg keyring (/etc/apt/trusted.gpg), see the DEPRECATION section in apt-key(8) for details.
W: GPG error: https://download.jitsi.org stable/ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B4D2D754E4DC7485
E: The repository 'https://download.jitsi.org stable/ InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

-------------

since the update wasgiving error for jitsi due to the key I had to stop. i COULD NOT CONTINUE WITH THE INSTALLATION